-1

Why this error is showing? Please solve it!!!!!!!:'( :@

Allowed memory size of 33554432 bytes exhausted (tried to allocate 1464 bytes)

I need a response immidiately!!!!!!

Votes + Comments
This is a forum. You cant 'order' for immediate response.
3
Contributors
4
Replies
5
Views
9 Years
Discussion Span
Last Post by khess
0

Dear Friend,

things are actually easy to prevent this:

In Function get_temp_urls located in spider.php a sql gets executed. The results of this sql get stored in an Array named $tmp_urls.

Limit the SQL results to say 0,100 and your spider will work fine as the Array is kept small. Now, if you think the spider will stop after 100 URLs, then you are wrong, he continues way as long as there is something to spider (depending on your settings)!

The SQL I use reads:
$result = mysql_query("select link from ".$mysql_table_prefix."temp where id='$sessid' limit 0,10");

This also speeds up the overhead before the spider starts and limits queries against the database!
Try it and be surprised!

:-) Keep smiling!

0

Try a bigger
"memory_limit"
in
"php.ini"
or

please put the following code in your php page for increasing the memory size without making any change in php.ini

ini_set("memory_limit","24M");

By default the memory size is 8M,So if you need more memory to execute any script code please try it.

0

Yes, try raising the memory limit. restart your web server after making this or any change to php.ini.

sudo apachectl restart

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.