Hello,
I am very new to JSP but I am familiar with Java. I am having an issue with some error messages I don't understand.

when I use this syntax:

<jsp:useBean id="search" class="search.SecSearchParams" scope="request">
<jsp:setProperty name="search" property="*"/>
</jsp:useBean>

I get this error:
The value for the useBean class attribute search.SecSearchParams is invalid.

I looked around and saw somewhere that for jsp 2.0 you should use type instead of class, but when I make that switch I get this error:
org.apache.jasper.JasperException: Unable to compile class for JSP:
An error occurred at line: 18 in the jsp file: /process.jsp
search.SecSearchParams cannot be resolved to a type
15: bundle = ResourceBundle.getBundle("forms");
16: }
17: %>
18: <jsp:useBean id="search" type="search.SecSearchParams" scope="request">
19: <jsp:setProperty name="search" property="*"/>
20: </jsp:useBean>
21: <%

it seems to recognize that the path is valid now, but I don't understand why it it is saying it can't resolve the class to a type. I've tried locating the class file at classes/search/SecSearchParams and at search/SecSearchParams but i get the exact same message. Where are the class files supposed to be located?

any help would be welcome

ok I solved the problem... the classes folder wasn't in the WEB-INF folder

This question has already been answered. Start a new discussion instead.