on the index.php page under create new database listed is no Priviligies. How can i correct this.

it seem to be working fine but then i think i played around with priviligies to get mamboserver working. after that all my databases were gone and i can't seem to add new databases as NO PRIVILIGIES is stopping me doing it.
Thanks in advance.

I have the same issue on my server -- no database priviliges. This is controlled by your system administrator, talk to them.

I recently did an install of Mambo, as well. Although the installation instructs you to create a database titled "mambo," this is not necessary. Whatever database you have access to will work -- the installation will add a "mos_" prefix to all of the table names to make them unique to Mambo.

The installation is relatively easy and shouldn't take longer than 20 minutes.

issue is how do i restore priviligies. does anyone know about mysql command for it.
i agree with you that installation is very easy.

also i took out old phpmyadmin and reinstalled new version 2.6.3-pl1 . but still NO PRIVILIGIES is displayed. how can i make this work back to normal as before when i played around with it.

I'm not much of a database sort of person. If it were me in that situation, I would probably reinstall the MySQL server -- it sounds like this is an issue with the server, and not phpMyAdmin. Sorry I can't be of more help.

Let me preface this by saying, I'm not a MySQL DBA. I do have a lot of experience, though.

In your phpMyAdmin conf file (config.inc.php), have you specified "root" as the user? Your "root" user should have all privs. Did you modify the root user's privs? I'm not even sure you can limit the "root" user. If so, you could paint yourself into a corner--only solution would be to re-install MySQL.

Are you working on Windows or Linux? If on Windows, open the MySQL Command Line Client and enter your root password. If on Linux, use the mysql command to connect as root to your mysql database. In the example below, replace mypass with your root password. "mysql" at the end of the line is the database name---mysql is the system database which is what you want to connect to for managing mysql users.

mysql --user=root --password=mypass mysql

Once connected as root, you can query the system tables to get information about users. If you are on Linux, adjust the output file below to something like /var/log/mysql_out.txt. Try this series of commands hitting ENTER after each:

tee c:\temp\mysql_log.txt
show databases;
use mysql;
show tables;
select * from user;
select * from db;
select * from tables_priv;

Now open the text file in your favorite text editor and peruse the results. You should see what users exist and what privs each has. If you need to fix something, check out the GRANT and REVOKE commands. See MySQL documentation. http://dev.mysql.com/doc/mysql/en/grant.html

More command line help:
http://dev.mysql.com/doc/mysql/en/mysql-commands.html
http://dev.mysql.com/doc/mysql/en/mysql.html
http://www.washington.edu/computing/web/publishing/mysql-client.html

in response to Troy.

I am using mysql 4.0.24 on windows 2000 pro. ansd in my config.ic file i've specified root as the user. i think i might have played around with phpmyadmin when this happened, ex i added new user for test but then deleted it. then it went like as it is.

effectively i have limited myself of using phpmyadmin. i had other stuff on my apache folder that can now not be run. cause it also deleted all databases except test that i think comes as default.

and finally i did try re-installing with new phpmyadmin version 2.6.3-pl1. and i have tried your code. All in all still same problem faced.

look i appreciated your feedback but would appreciate you have any new ideas. thanks once again.

Whoa! You say entire databases were dropped? Then you definitely have much bigger issues than simply a user acct with messed up privileges. So databases are missing, and root does not seem to have root privs---at least not when in phpMyAdmin.

Do you have any data left that you need to keep? I mean, did you lose all your valuable tables? If so, uninstall MySQL completely, and re-install. Also, delete your current phpMyAdmin files and start over with a fresh download of latest stable release. Sounds like you need to start over. If you have data you need to keep, export it into csv files so you can import it after a total re-install.

Thanks.
I will try out your valuable advice. I will delete phpmyadmin, then uninstall mysql. i suppose deleting mysql would be to delete mysql folder and also look at add/remove in control panel right. and then re-install both. And yes all tables/databases gone. but nothing to worry about for me cause all apps were used like mambo, oscommerce, phpnuke, etc were used for test purposes.

will keep you updated on the progress. cheers.

To uninstall MySQL on Windows, use Add/Remove Programs Controlpanel. Do not delete files first.

My guess is something screwed up big time and everything reset itself. Just create a new user and grant privileges.

well i couldn't see any way to delete it in add/remove control panel but just deleted the whole folder. and reinstalled.

however, still same problem after reinstall. ie no priviligies. i have 2 utilities. in mysqladministrator i see on server connections this 'mysql error number 1044. Access denied for user: '@localhost' to database 'mysql'

and in mysql control centre for ex i tried shutting down the message i got was ERROR 1227: access denied. You need the shutdown privilige for this operation.

can you giver me a command to make new user with proper priviligies although i tried that from mysql control centre without success.

so once again more food for thought.

I'm afraid your scenario is a unique problem--one that I'm personally unable to troubleshoot beyond what I've already told you. A clean install of MySQL 4 on a "normal" Windows 2000 computer does not display the issues you describe. Several things you describe are not "normal", so I'm not sure what you've done or what is "wrong" with your system.

You mention there was nothing in your Add/Remove Programs Controlpanel, but when you use the MySQL Windows Installer (msi file), it does indeed put an entry in this Controlpanel that you can use to uninstall. (See attached screenshot.)

If you download the Windows Installer (msi) of MySQL 4.1, run it, and follow the installation wizard, you should not have any issues. My WAMP HOWTO at http://www.troywolf.com/articles explains how to get and install MySQL4.1 on a Windows XP computer. The MySQL part of my instructions are identical for Win2000.

By default, you'll have a MySQL user named "root". The installer will prompt you for a root password. By default this root user will have full admin privs over your MySQL service--ability to create users, databases, etc.

Good Luck.

Attachments mysql_add_remove.gif 14.22 KB

ok well i did find the entry in add/remove and did remove it. then i downloaded the msi file of mysql4.1.12a. ran configuration wizard and i think in one of the last screens the processing configuration it was not able to start service. message said 'Cannot create windows service for Mysql. Error:0'

to install service is like this ight; mysql-nt --install. but we have not installed it completely yet so how do we start the service.

i'm sure this should be a piece of cake for you. cheers.

thanks guys. i finally unistall old mysql version by removing mysql from task manager. otherwise it would not allow me to delete the directory. And have just installed mysql new verion 4.1. this time i will be carefull not to play around with priviligies.
all i want to do is to add password to root username. as it is its just root and no password.

many thanks to all of you again. cheers

on the index.php page under create new database listed is no Priviligies. How can i correct this.

it seem to be working fine but then i think i played around with priviligies to get mamboserver working. after that all my databases were gone and i can't seem to add new databases as NO PRIVILIGIES is stopping me doing it.
Thanks in advance.

I had the same problem, 1st however it let's you create a database name do that - Example: users_ (The underscore must be after the name ok save that)

Now be sure you have Editedphp your password and saved it...

Now do you know your Username from your server... It is usually is your websites name but it has a first part than a .(Dot) followed by your websites name.com
Example: your websites name is john.com - Your user name would be : john.john.com

Okay after you have that Go to log on but! -
Erase everything on the Username and Password entry. Start new Re-Type It All Correctly In The Username and Password - It should work fine, Good Luck!

This article has been dead for over six months. Start a new discussion instead.