0

Hi friends


I am trying to install drupal-6.16 to my local server...I am using XAMPP server on windows xp. but i am getting this error massage.

Warning: fopen(./sites/default/default.settings.php) [function.fopen]: failed to open stream: No such file or directory in E:\local server\xampp\htdocs\www\drupal\includes\install.inc on line 188

Warning: Cannot modify header information - headers already sent by (output started at E:\local server\xampp\htdocs\www\drupal\includes\install.inc:188) in E:\local server\xampp\htdocs\www\drupal\includes\install.inc on line 618

Warning: Cannot modify header information - headers already sent by (output started at E:\local server\xampp\htdocs\www\drupal\includes\install.inc:188) in E:\local server\xampp\htdocs\www\drupal\includes\install.inc on line 619

but I cahnged the default.settings.php file to settings.php


what should I do...?

please help me...I need a solution as soon as possible

Thanx

Cheers

Umanda Jayo Bandra

3
Contributors
4
Replies
5
Views
7 Years
Discussion Span
Last Post by rajarajan07
0

please rename the settings.php with a correct name as well as don't give space in front and back OK.or else you remove all the installation files in pack and reinstall the pack.

0

thank you all gyes...

I achieved it....

the problem is I remove the default.settings.php in ../sites/default/ directory. In drupal installation

ok this is what should we do if we are getting the following error massage.

Warning: fopen(./sites/default/default.settings.php) [function.fopen]: failed to open stream: No such file or directory in E:\local server\xampp\htdocs\www\drupal\includes\install.inc on line 188

Warning: Cannot modify header information - headers already sent by (output started at E:\local server\xampp\htdocs\www\drupal\includes\install.inc:188) in E:\local server\xampp\htdocs\www\drupal\includes\install.inc on line 618

Warning: Cannot modify header information - headers already sent by (output started at E:\local server\xampp\htdocs\www\drupal\includes\install.inc:188) in E:\local server\xampp\htdocs\www\drupal\includes\install.inc on line 619

First take a copy of default.settings.php
Second rename the copy default.settings.php file into settings.php

now after creating database can continue the installation process.

if got any error again please clear the resent history(cookies cache...etc)

again you got a error ( Specially in old XAMMP ) please edit php.ini file.

in php.ini file please check the memory limit.keep it 128MB if it is not 128MB change it in to 128MB


; Maximum amount of memory a script may consume (128MB)
; http://php.net/memory-limit
memory_limit = 128M

save the php.ini file and restart your local server and try again.

still you have a problem, Remove all the installation files and try installing the XAMPP in the c drive and try again..

Thank you..

Cheers..

Edited by umandajayo: modification

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.