3
Contributors
5
Replies
6
Views
7 Years
Discussion Span
Last Post by simi pillai
0

Are you running it from Visual Studio in debug mode? or from "view in browser"?

Or is the site live and uploaded to a web server and giving this error?

Any chance you can provide an example of the code you're using for the authentication popup (minus any user/password sensitive information of course) so we can see what your code is doing and possibly help troubleshoot for you?

Love to help but without more info I'm afraid there's not much to work with here :)

0

no I want to run it on the web browser not visual studio 2005.This is website is my study project.first i publish that solution and give websharing then try to run that at that time it shows error.

0

Ok, so what I'm reading is that you are getting this as a result of viewing a published page on a web-server, is that correct?

Again, it would still help to have some code samples provided of the portions of the application that are responsible for generating authentication. Alternately, if your application is not what is causing the authentication request then it is possible that your hosting directory was set up incorrectly in your web-server and is requiring you to log in to the directory which would be unrelated to the application.

As indicated above, it is difficult to troubleshoot without more information so if you can provide some details on the following it might help figure out the source of the problem:

  • Is the web-app hosted locally on your development machine or on an external web-server?
  • Is the directory the web-app is hosted from a password protected directory on your web-server?
  • Is there a portion of your code that requests user authentication within your web-app? If so, can you please share the code so we can see it.

In the end your authentication issue is derived from 1 of 2 places, your application code or your web-server. Knowing which one will majorly narrow down the troubleshooting to solve your problem :)

0

* yes locally
* not pwd protected
* yes a portion ask the username and password
:)

0

Server Error in '/PrecompiledWeb2' Application.
________________________________________
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized configuration section 'connectionStrings'

Source Error:

Line 10: <configuration>
Line 11: <appSettings/>
Line 12: <connectionStrings/>
Line 13: <system.web>
Line 14: <!--

Source File: F:\9july\project\Solution\PrecompiledWeb1\WebUI\web.config Line: 12
________________________________________
Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032


Web.config

<?xml version="1.0"?>
<!--
Note: As an alternative to hand editing this file you can use the
web admin tool to configure settings for your application. Use
the Website->Asp.Net Configuration option in Visual Studio.
A full list of settings and comments can be found in
machine.config.comments usually located in
\Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
<appSettings/>
<connectionStrings/>
<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="true"/>
<!--
The <authentication> section enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<!--
The <customErrors> section enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>
-->
</system.web>
</configuration>

Edited by simi pillai: error

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.