environment variable1: %JAVA_HOME%\bin;%JC_HOME%\bin;C:\Program Files\Apache Software Foundation\Tomcat 5.0\common\lib\servlet-api.jar;

environment variable2: C:\j2sdk1.4.1_07

hav 2 submit few progrms at college using servlets...n getting the errors mentioned abov...plzzzzzz hellllllppppppppp....

I think these packages are part of JavaEE, so if you have Java SE you need to upgrade. And if you are really still on 1.4.1 you desperately need to update!

append your environment variable to resolve the problem

variable 1:
JAVA_HOME: C:/Program Files/Java/Jdk 1.4.1/bin;

variable 2:
classpath: C:/Program Files/Apache Software Foundation/.../lib/servlet-api.jar;

it'll solve your problem

You didn't have to put it in path. Telling your IDE where to find this library is enough...

i tried compiling those prgrmz in command prompt bt of no use(using d mthds u al hv suggstd...)...

1. You better start using proper English
2. Post exactly what you tried, what commands you used and what errors you getting