Hello,

I'm working on a project that needs to be done in PHP, however, everything has to be done locally. To test files that I'm editing I have installed Xampp on my computer. As far as I can tell, I have installed everything properly. When I load up this page, the template appears but I get an error at the bottom saying:

Fatal error: Class 'Templates' not found in testfile.php on line 4

Here is the page:

<?php

require_once 'test/Templates.php';
Templates::$options['version'] = 3;
$page = Templates::factory('Fixed');
$page->titlegraphic     = '<h1>Hello world</h1>';
$page->maincontentarea  = '<p>Testing the main content area.</p>';
echo $page->toHtml();

?>

Any help with how to fix this would be greatly appreciated! Thanks in advance!

Actually just solved the issue. Is there a way I can delete/lock the thread..?

Member Avatar
diafol

No, unlikely. DW have una paura nera of deleting posts. You can however mark it solved so that others don't waste their time with it when they see it in the list.

can you please tell me how did u solve it, please i need your help. having the same problem.

I am facing the same Problem Waiting for the replies.