0

I am beginner in ruby and I use ruby 1.9.2 in windows 7. I have a problem with installing gems.for example : 1 - when I typed gem install RedCloth , command prompt give this error:

" ERROR: Error Installing RedCloth: invalid gem format for C:/Ruby192/lib/ruby/gems/1.9.1/cache/RedCloth-4.2.7-x86-mingw32.gem "

2 - and when I typed gem install hpricot command prompt give me this error :

" ERROR: Error Installing hpricot: The 'hpricot' native gem requires installed build tools. Please update your PATH to include build tools or download the DevKit from 'http://rubyinstaller.org/downloads' and follow the instructions at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit' "

please help me to solve this problem. Special thanks

2
Contributors
1
Reply
2
Views
6 Years
Discussion Span
Last Post by Taywin
0

Sorry for a very late reply.

For the first error, it seems that you have gem cache problem with certain incompatible dependencies. Search Google using "ruby gem invalid gem format" for further possible answers.

For the second error, you need a package to compile the incoming gem package because the package is not ruby. It is on Windows, so I am not really sure how to get the package for compiling it... :(

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.