0

Hello, I am having trouble in starting apache. I had vista before and it worked well. Now I installed win 7, and have trouble.

When I want to start, I get messages:

Busy...
Apache started [Port 80]

I tried turning off skype, because it was causing problems often. But didn't help. Then I tried ediding httpd.conf file and changed some lines:

Listen 8080

ServerName localhost:8080

But apache is still not starting. And gives the same error messages:

Busy...
Apache started [Port 80]

the port is still 80, looks like it does not read the file where I made the changes.

Any thoughts what could I do?

Edit: also I tried netstat -ano - did not find the process who is using 80 port

Edited by SPeed_FANat1c: n/a

6
Contributors
30
Replies
37
Views
5 Years
Discussion Span
Last Post by SPeed_FANat1c
0

I have had this problem many times and there is a very simple solution. Do the following.
1. Open C:\xampp\apache_stop.bat file
2. Open C:\xampp\control.exe
3. Single click Start Apache and wait 30 seconds before moving the mouse or clicking anything else otherwise you will need to repeat the above three steps.

-1

you meant xampp-control.exe in step 2?

yes indeed. They call it different names in different versions.

0

If You have Skype, go to skype options > advanced > connection and unmark option: Use port 80 and ....

0

If You have Skype, go to skype options > advanced > connection and unmark option: Use port 80 and ....

I done that, and I even turned off skype. This used to work on vista, but doesn't this time

0

Maybe I will if I don't find a way to fix it. But I am used to xampp, some configuration, on wamp there migth be some other things I don't know. But thanks of course for this advice also

0

Maybe I will if I don't find a way to fix it. But I am used to xampp, some configuration, on wamp there migth be some other things I don't know. But thanks of course for this advice also

Actually configuring Wamp is as breeze as right clicking the tray icon and behold all configs are there :)

0

Actually configuring Wamp is as breeze as right clicking the tray icon and behold all configs are there :)

I find from past experiences Wamp is a devel to configure especially to enable modules such as mssql. It is better to deal with xampp. I would suggest doing Ctrl+alt+del and end task to apache then try to enable it again but once again only single click. And as I said, I strongly recommend not to use wamp as it will cause you problems for enabling modules down the track.

0

ok, thanks, maybe its really better soft than xampp :) then I wonder why others use and recomended me xampp when I was new to php

edit: didn't see the message by cwarn23.

Ctrl+alt+del and end task to apache then try to enable

I'll give it a try

Edit2:

didn't see appache process in task manager..

Edited by SPeed_FANat1c: n/a

-1

didn't see appache process in task manager..

It should be under services in the task manager

0

ok, I tried to look at services, and didn't found something that would be similar to appache. Or I just don't recognize.

You can see in attached picture.

Attachments 80.png 511.85 KB
-1

Did you try and single click on the start button for apache so that it becomes green? Does it stay green? If not then you may need to look both in services and processes for the item named "apache" or possibly "httpd" and end task to it then back in xampp single click the start button.

0

Did you try and single click on the start button for apache so that it becomes green? Does it stay green? If not then you may need to look both in services and processes for the item named "apache" or possibly "httpd" and end task to it then back in xampp single click the start button.

Yeah, I tried, and it does not become green, not even for a short time. I took a look in sercives and in procesess for "apache" and "httpd" and didn't find any of them :/

-1

Then try opening apache_start.bat and see if there are any error messages. If there are then post them here or if there are not then you might want to reinstall xampp. To keep the mysql data you simply copy the directory xampp\mysql

0

do a port check from the control panel of XAMPP. See which program is occupying port 80 and kill it.! U know, u can even use IIS which is almost similar to XAMPP but it comes built in with Windows...

0

Then try opening apache_start.bat and see if there are any error messages. If there are then post them here or if there are not then you might want to reinstall xampp. To keep the mysql data you simply copy the directory xampp\mysql

Apache 2 is starting ...
Syntax error on line 502 of D:/Program Files (x86)/xampp/apache/conf/httpd.conf:

SSLSessionCache: Invalid argument: size has to be >= 8192 bytes

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .

so I searched in this file for 'SSLSessionCache' and I'll paste it:

<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLSessionCache "shmcb:logs/ssl.scache(512000)"
SSLSessionCacheTimeout 300
</IfModule>

do a port check from the control panel of XAMPP. See which program is occupying port 80 and kill it.! U know, u can even use IIS which is almost similar to XAMPP but it comes built in with Windows...

if from this error jyou will not kwow what should I do, then I'll try this. When I want to check port, I click status?

When I click status, one of the list items is httpd 'state 0, service 0 ,and so on, all zeros, and port 80

0

found your problem. You have placed xampp inside "Program Files". That is a nono for this program. The manual strictly speaks of saying install xampp at "C:\xampp\". The reason being is that "Program Files" has a space in it and also has special permissions. So perhaps you could cut and paste the xampp directory to C:\xampp\ then after making sure every single file has been cut and pasted, reinstall the services by ticking the tickboxes in the control.exe and single click start to see if it turns green. If it fails then try starting it from the bat file and post here what errors come back.

0

ohk! "port check" is not there.Below SCM that port check button should be.Manually u can port check from XAMPP directory by clicking on XAMPP-Portcheck.exe the port check option is not der. My frnd had the same problem. Just like ur screenie
Do one thing. type http://localhost in ur browser and see what happens. post that here and i'll tell u what to close. One program is using ur port 80. might be IIS, teamviewer,skype or something else too. ur supposed to close that!

0

first: try to scan the ports in your pc to check the apache port was not used by another program

0

@cwarn23: hey actually you can place it anywhere. Especially when you choose "make portable" option. I have been using XAMPP in program files. Works neat

@evstevemd: Actually its not WAMP. It's called WAMPServer and XAMPP is a WAMP cum LAMP
And I think he might have same problem in WAMPServer too because the port must be occupied or if not then its just the XAMPP config. Well, Windows has an inbuilt WAMP called IIS. YOU can use that too, and YOU can choose your own kind of error pages and even the port to sit on! Use control panel>Programs>Turn Windows Feature On And Off to add IIS. In Windows XP, its in the uninstall programs menu. Something like "add/remove components"

0

@timetraveller92
The mysql service and other parts of the xampp package will not function correctly if it is located in a path with white spaces. So for that reason it must be located in a path without spaces. And even if you weren't to use those modules that malfunction because of the path, in Windows Vista and Windows 7 (but not XP) the "Windows" + "Program Files" + "Users" directories carry special security permissions which also cause xampp to malfunction. For this reason xampp also cannot be placed in those three directories on Windows Vista and Windows 7. It is all in the official documentation and no I can't give you the link (although I would like to) because there is a bit of an disagreement with happygeek if I can provide links.

0

@evstevemd: Actually its not WAMP. It's called WAMPServer and XAMPP is a WAMP cum LAMP
And I think he might have same problem in WAMPServer too because the port must be occupied or if not then its just the XAMPP config. Well, Windows has an inbuilt WAMP called IIS.

Thanks for correction. Sometimes I tend to use terms loosely :)
IIS IMO is commercial, am I wrong?

0

@evstevemd: I'm not clear about it but I'm pretty sure I read somewhere in the Microsoft website that "IIS is free" although not available for download. And as per my observation it is free, you can just use add/remove components menu to add IIS. In windows 7, control panel>programs>turn on and off features and add it. I have a feeling that there might be some commercial addons but do tell if you know more regarding it.

@cwarn23: Currently I'm using xampp in the root of C drive but I have used it before in program files. My reply is purely based on experience, still you say that the documentation states otherwise. Interesting..!

0

@evstevemd: I'm not clear about it but I'm pretty sure I read somewhere in the Microsoft website that "IIS is free" although not available for download. And as per my observation it is free, you can just use add/remove components menu to add IIS. In windows 7, control panel>programs>turn on and off features and add it. I have a feeling that there might be some commercial addons but do tell if you know more regarding it.

Can you link me to article?

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.