I really am stumped by this problem and would appreciate some help..
I am tryiing to build a site on a computer running Wiindows XP and using, mainly, FrontPage 2003 although I have also used Notepad to try and solve a problem that has arisen.
The problem is that IE6 throws a securiity alert whenever I insert Javascript code into a page.
Now, I have no problem surfing the Web and viewing Javascriipt-enhanced pages. Indeed I can download such pages to my hard drive and view them off-line wiithout any hitch arisiing.
The problem only seems to occur with pages I create myself - every time I view such a page, IE6 triggers the ActiveX security alert.
The problem cannot be with the browser's security settings as I have no problems viewing pages with code inserted that others have created.
I'd be very grateful for any advice...

I am betting that you are just doubleclicking the file to open it. Yes? If you put it on your site and browse to it as a normal user would, you probably aren't going to get that problem.

I am betting that you are just doubleclicking the file to open it. Yes? If you put it on your site and browse to it as a normal user would, you probably aren't going to get that problem.

Thanks!
It worked first time.
I had been blaming Windows XP as I had no problems viewing the pages in question on a nachine running Win 98 and thought I had to alter Administrator Privileges or something along these lines. Anyway, I am now happy once again.
This is a great forum BTW. I got an excellent answer within hours to a problem that was causing me a big headache.

Internet Explorer has a 'feature' which disables 'Active Content' aka Javascript in local files. To disable it, go to Tools > Internet Options > Advanced Tab and scroll to Security. Check the box labeled 'Allow Active Content to run in files on My Computer'. Restart your browser and it should be all set

This article has been dead for over six months. Start a new discussion instead.