I bought a copy of php probid. Everything on it looks ok. I have looked at other sites using it and obviously they got it to work, I have installed it on my local host for testing. I am using xampp 1.7.1 becuase the script require gd library and zend optimizer and the php version in later versions of xammpp will not work. The problem is when I upload either a media file or digital good, the uploader gets stuck. Now I looked at several sites hat have this working. The digital goods are supposed to zip or rar files. The media file are either avi, mpeg files. I tried changing the upload size settings in the admin. I am thinking the settings are wrong in the server?


Turn on your xampp server and then click -> http://localhost
On your left panel, click on the phpinfo().

I need the following values
1. Loaded configuration file.
2. post_max_size
3 upload_max_filesize

  1. Loaded Configuration File C:\xampp\php\php.ini
  2. post_max_size 64M
  3. upload_max_filesize 64M

open xampp/php/php.ini with your notepad. Before doing anything on this file, make sure to make a back up copy of this file by saving it as php.iniDeFault.

Change post_max_size and upload_max_filesize values to 300M, make sure the

Read more about your scripts requirements. Normally they want you to have higher values on
max_execution_time .. the default settings provided by xampp and any other php distros are set to about 30 or 60. This value will not suffice waiting for your upload to finished.

Change max_execution_time = 30 to your script's requirements
Change max_input_time = 60 to your script's requirements.

If you have a really good memory installed on your desktop, add more memory for your xampp's consumption, by changing this value

memory_limit = 128M Normally 300M will suffice.

Check the recommended settings of your software for register globals. If it is requiring ON setting other than OFF which is a default setting, change the value from off to on. WARNING! CHANGE THIS ONLY PER YOUR SCRIPT REQUIREMENTS. If they don't want you to turn this on, DO NOT TURN IT ON.

register_globals = Off

Make sure this value is set to ON.
file_uploads = On

Once again check for your software's recommendation about the allow_url_include, by default this is set to OFF due some big security issues. If they script requires you to turn this ON, that is the only time this has to be ON.

Does your script requires eAccelerator or Zend plugin?,.. Yes? Change this

;zend_extension to this zend_extension

Xdebug requirements.. does your script requires you to turn on the xdebug during devemopement? If yes, find

and change this -> ;zend_extension = "\xampp\php\ext\php_xdebug.dll" to this zend_extension = "\xampp\php\ext\php_xdebug.dll"

That's all I think of right now, please DO NOT hesitate to post your script's server requirements here, so that I can help you more..

Save all of your changes, and restart exampp.. THIS IS IMPORTANT..

This is the most common misunderstanding between the developer and the script users. Most script users are in the assumption of a plug and play script. Just upload it to the server, and it will work. Not even cosidering the server requirements of the script. On the other hand, developers sometimes fail to disclose their server requirements to the user.

The requirements are on phpprobid. I will change these settings..

Your script wants you have ioncube or Zend(engine and optimizer).. I am not quite sure what did they mean by ioncube.. I am in the assumption here that they want you to have an ioncube loader for the script to run. If that is what they want, you can download the zip file that is MATCHING your operating system and the PHP version currently installed on your xampp. http://www.ioncube.com/loaders.php.

Before attempting to download the zip file above, just make sure everything are working on your site. If one of your pages says "ioncube loader is missing", then that is the only time you install the loader. I will show you how to get into the ioncube loader extension installation later if it is needed. Otherwise, we will just have wait for the ioncube loader errors to appear.

As far as the GD requirements, the latest xampp already met the version requirements.

phpprobid is pretty much secretive on other server requirements they have, because they are targetting people to sign-up for their hosting package currently being offered by them. I am pretty sure about the php.ini file for the uploads, but some requirements needs some entries on the apache/conf/ directory which I don't really know because the site don't even mention any other requirements. Lets keep our finger crossed and hope that is all to it.

Just to be safe and to prevent your server from terminating the upload script, set the following like this

max_execution_time = 1000
max_input_time = 1000

Veedeoo, Are you the mathematics wiz kid from Princeton University? He also goes by handle of Poorboy and Morpheus Linux.

It seems to upload files of a certain size. The files I am trying to upload are between 100KB and several megabytes. WHat are the appropriate settings.

Since you are still running your script on localhost, your limit is all based on how much drive space you have on your desktop. VPS hosting like the ones offered by certified or offered by HostV comes in with a default settings of 300M to 600M.. So, if you will be developing and targetting this environment the php.ini file settings for upload limit will be

post_max_size = 600M
upload_max_filesize = 600M

Remember, regardless of the consequences, these two values must be equal at all times. As you increase the size of your post_max_size and upload_max_filesize, the max_execution_time and max_input_time must also increase proportional to the upload speed of the user's internet connection. An estimated of about 150kb/s is pretty much the average across the globe. Keep in mind that people who are connecting and uploading to your site on a very slow connection will not be able to finished their upload beyond 50MB.. the server will just close its door, because of the max_execution time has been reached or it has ran-out. Be mindful that anything beyond the 75MB threshold everything seems to take forever. If the script timed out, while the upload is in progress, everything will be in the TMP directory unprocessed, requiring you do another upload. The is the reason why youtube limit the upload file size, inspite of all the benefits of running their site on super servers.

If you will be expecting an upload size of more than 200MB per session, then I don't think php script upload is the right choice for your site. It would take about 35 to 58 minutes for every 200MB. So, it is not that the php script uploader will not work, but it is just tremendously slow on the client side. You may want to utilize jquery and flash uploaders like the one found on SWFupload, uploadify and others in this category. These uploaders keeps the browser's awake and so as the ocnnection, so on jquery refresh, the max_execution time is being reset back to default value. If you go by this method, then you can easily increase post_max_size and upload_max_filesize to about 1000M, or it could be more depending on your hosting account's limitations.

For bigger AVI and MP4 files, say more than 700MB.. files should be uploaded in chunks. Then ffmpeg can be use to combine these chunks into one file.

Another alternative is to have another hosting account ONLY to serve the big uploads, and then package these files and move it to your ultimate destination by way of php script. PHP upload script is fast if the transfer is lateral server to server. For example if we have another domain to handle all the heavy upload processing, and then a second domain where the uploaded items is offered for sale. The lateral transfer speed between these two will be around 100MB/s , so the 1gb file would only take about 1 to 2 minutes or less to transfer with the approximation of the speed bump is already included.

Pure PHP upload script is just not reliable on bigger chunk of file compared to flash/jquery assisted script, when use to interact with browser uploads, but server to server, it is ligthning fast.

Veedeoo, Are you the mathematics wiz kid from Princeton University? He also goes by handle of Poorboy and Morpheus Linux.

I hope you are not Dr. Einstien ????? Well, I am attending PU and I am also the PoorBoy and the Morpheus, but I don't know about being a Math wiz kid. That's rather a label they put upon my head. PU?? Not for long though, because I will be moving to CALTECH this June. PU says I must report to CALTECH immediately. So, I am preparing and looking forward going back to California. My only worries is that, my prospective classmates in CALTECH are pretty old some of them are even almost turning back into a clay, they can be my grandfathers or even great great and great grandfathers (I think??), and they don't have anyone like my age. It's ok, I will just hang-out in the library writing programs and visit DaniWeb, my forums, and my blog during my freetime.

I'm not a devleoper, but there some mods for this. None of the files could be over 10 MB. I'm mostly concerned about users being able to sell ebooks.


these should be more than enough for your purpose. eBooks at the least don't do more than 600M. Just make sure when the script is moved to production server, tell the hosting company to adjust your server configuration based on what we already covered here.

Normally, scripts that support uploads have a minimum requirements as shown below..

max_execution_time = 1000
max_input_time = 1000
open_basedir = (no value)

; these are close to maximum
upload_max_filesize = 600M
post_max_size = 600M

Others may require safe_mode = off and register_argc_argv = On. However, due to the nature of your script, I don't recommend it, unless it is recommended by the script and mod authors. The first setting (safe_mode = off) prone to security hole and the second (register_argc_argv = On) is like giving a consent on your script to become a server resources hog. I am not really familiar with probid. So, I can't say much about it, but I can only discuss more about the server configuration settings and safety.

Okay this is solved. Very helpful thanks.