0

I have installed MySql 5.0.19, Apache 1.3.34 and PHP 5.1.2(SAPI Module) and configured both php.ini and httpd.conf files such as extension_dir,doc_root,LoadModule,AddModule,AddType etc. on myWindows Xp (FAT32) system. When I invoke test.php containing the code <?php phpinfo(); ?> on the browser, the sorce code itself gets displayed without error. Where is the problem, please help me.

3
Contributors
4
Replies
5
Views
11 Years
Discussion Span
Last Post by Viji
0

You sure you're calling the file from the server, and not from the local file? That is to say, are you opening your file by double clicking it in explorer, or are you calling it by typing an address like this in your browser address bar -- http://localhost:8080/test.php ? If you call the file directly from explorer, you'll see the code. Calling it from the server tells the PHP engine to process the PHP file and send the reesults to the browser.

0

go to httpd.conf that is present in conf folder.

Search for DirectoryIndex and add the index.php as the First parameter .

DirectoryIndex index.php index.html index.shtml.

Then invoke the test.php in the browser . I think it should work..

Cheers,
viji

0

I entered index.php as you told in httpd.conf file. Still it's not working

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.