0

Hello,

I am stuck with tryting to upgrade PEAR fri 1.7.2 to newest version. I want to install PHP unit and it does not like 1.7.2 version of pear.

I managed to get till there:

C:\Users\Darius>pear upgrade pear
WARNING: channel "pear.php.net" has updated its protocols, use "channel-update p
ear.php.net" to update
WARNING: "pear/Console_Getopt" is deprecated in favor of "pear/Console_GetoptPlu
s"
pear/Console_Getopt requires PEAR Installer (version >= 1.8.0), installed versio
n is 1.7.2
downloading PEAR-1.9.4.tgz ...
Starting to download PEAR-1.9.4.tgz (296,332 bytes)
.............................................................done: 296,332 bytes

downloading Archive_Tar-1.3.10.tgz ...
Starting to download Archive_Tar-1.3.10.tgz (18,294 bytes)
...done: 18,294 bytes
downloading Structures_Graph-1.0.4.tgz ...
Starting to download Structures_Graph-1.0.4.tgz (30,318 bytes)
...done: 30,318 bytes
ERROR: failed to mkdir C:\php\pear\docs\Archive_Tar\docs
ERROR: failed to mkdir C:\php\pear\docs\Structures_Graph\docs\html\media
ERROR: failed to mkdir C:\php\pear\docs\PEAR

Why it want to creant in C/:php? C:/php is definitely not my apache directory. There should be somewhere pear.ini in php instalation, but I cannot find it. Probably there I should adjust something.

But when I run config show, it shows something.

C:\Users\Darius>pear config-show
CONFIGURATION (CHANNEL PEAR.PHP.NET):
=====================================
Auto-discover new Channels     auto_discover    <not set>
Default Channel                default_channel  pear.php.net
HTTP Proxy Server Address      http_proxy       <not set>
PEAR server [DEPRECATED]       master_server    pear.php.net
Default Channel Mirror         preferred_mirror pear.php.net
Remote Configuration File      remote_config    <not set>
PEAR executables directory     bin_dir          E:\other\xampp\php
PEAR documentation directory   doc_dir          C:\php\pear\docs
PHP extension directory        ext_dir          E:\other\xampp\php\ext
PEAR directory                 php_dir          E:\other\xampp\php\pear
PEAR Installer cache directory cache_dir        C:\Users\Darius\AppData\Local\Te
mp\pear\cache
PEAR configuration file        cfg_dir          C:\php\pear\cfg
directory
PEAR data directory            data_dir         C:\php\pear\data
PEAR Installer download        download_dir     C:\Users\Darius\AppData\Local\Te
mp\pear\download
directory
PHP CLI/CGI binary             php_bin          E:\other\xampp\php\.\php.exe
php.ini location               php_ini          <not set>
PEAR Installer temp directory  temp_dir         C:\Users\Darius\AppData\Local\Te
mp\pear\temp
PEAR test directory            test_dir         C:\php\pear\tests
PEAR www files directory       www_dir          C:\php\pear\www
Cache TimeToLive               cache_ttl        3600
Preferred Package State        preferred_state  stable
Unix file mask                 umask            0
Debug Log Level                verbose          1
PEAR password (for             password         <not set>
maintainers)
Signature Handling Program     sig_bin          c:\gnupg\gpg.exe
Signature Key Directory        sig_keydir       C:\Windows\pearkeys
Signature Key Id               sig_keyid        <not set>
Package Signature Type         sig_type         gpg
PEAR username (for             username         <not set>
maintainers)
User Configuration File        Filename         C:\Windows\pear.ini
System Configuration File      Filename         C:\Windows\pearsys.ini

could you tell me what to do next with that pear which is wasting my time? It gots so annoyting when I cannot do a simple thing - upgrade software :(

2
Contributors
4
Replies
5
Views
4 Years
Discussion Span
Last Post by McLaren
0

Thansks. I tried:

To update your PEAR installation, request http://pear.php.net/go-pear.phar in your browser and save the output to a local file go-pear.phar. You can then run

php go-pear.phar

in a Windows Command Prompt to start the update process.

After changing php.ini , you need to restart your web server.

instalation went well, but my pear version is still 1.7.2

0

Are u runing cmd with admin privs? Try rerunning te pear upgrade pear but make sure you are in the php directory

0

Are u runing cmd with admin privs? Try rerunning te pear upgrade pear but make sure you are in the php directory

I think I am, I am using admin acc on windows, so at cmd its probably admin as well.

The directory left from last time was php, so I tried again to see what happes, but I ran php go-pear.phar in that directory. I am not sure if I ran it in php directory previous time, but this time it worked :) its now 1.9.4 :) Weird, but ok now :) Thanks for help.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.