-1

I am getting an error..Need help..
" Parse error: syntax error, unexpected T_STRING in C:\xampp\htdocs\test2.php on line 24";
line 24 is --"header("Content-Type: application/xls");"--

<?php
$DB_Server = "localhost"; //MySQL Server 
$DB_Username = "root"; //MySQL Username 
$DB_Password = "";             //MySQL Password 
$DB_DBName = "test";         //MySQL Database Name 
$DB_TBLName = "sample"; //MySQL Table Name
$filename = "abc";         //File Name
//create MySQL connection
$sql = "Select * from $DB_TBLName";
$Connect = @mysql_connect($DB_Server, $DB_Username, $DB_Password)
    or die("Couldn't connect to MySQL:<br>" . mysql_error() . "<br>" . mysql_errno());
//select database
$Db = @mysql_select_db($DB_DBName, $Connect)
    or die("Couldn't select database:<br>" . mysql_error(). "<br>" . mysql_errno());
//execute query
$result = @mysql_query($sql,$Connect)
    or die("Couldn't execute query:<br>" . mysql_error(). "<br>" . mysql_errno());
$file_ending = "xls";
 
//header info for browser
header("Content-Type: application/xls");
header("Content-Disposition: attachment; filename=$filename.xls");
header("Pragma: no-cache");
header("Expires: 0");
 
/*******Start of Formatting for Excel*******/
//define separator (defines columns in excel & tabs in word)
$sep = "\t"; //tabbed character
 
//start of printing column names as names of MySQL fields
for ($i = 0; $i < mysql_num_fields($result); $i++) {
echo mysql_field_name($result,$i) . "\t";
}
print("\n");
//end of printing column names
 
//start while loop to get data
    while($row = mysql_fetch_row($result))
    {
        $schema_insert = "";
        for($j=0; $j<mysql_num_fields($result);$j++)
        {
            if(!isset($row[$j]))
                $schema_insert .= "NULL".$sep;
            elseif ($row[$j] != "")
                $schema_insert .= "$row[$j]".$sep;
            else
                $schema_insert .= "".$sep;
        }
        $schema_insert = str_replace($sep."$", "", $schema_insert);
 $schema_insert = preg_replace("/\r\n|\n\r|\n|\r/", " ", $schema_insert);
        $schema_insert .= "\t";
        print(trim($schema_insert));
        print "\n";
    }
?>
3
Contributors
4
Replies
10
Views
4 Years
Discussion Span
Last Post by LastMitch
0

sorry i might have deleted 2 lines in my code above...
the actual error is in
--"header("Content-Type: application/xls");"--

2

sorry i might have deleted 2 lines in my code above...

Did you do that intentionally to cover up the actually error?

--"header("Content-Type: application/xls");"--

Try to change this line:

$file_ending = "xls";

header("Content-Type: application/xls");
header("Content-Disposition: attachment; filename=$filename.xls");

to this:

$file_ending = ".xls";

header("Content-Type: application/vnd.ms-excel");
header("Content-Disposition: attachment; filename=\"$filename\"");

Edited by LastMitch: grammer

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.