0

Hi, I can not create a database in the phpmyadmin. How do I enable the privilidges so I can create a database? a1f9ac111e8c5f99ec073858a8c29eefa1f9ac111e8c5f99ec073858a8c29eef

6
Contributors
42
Replies
97
Views
4 Years
Discussion Span
Last Post by <M/>
1

Are you logged in as "root"? If you are, you might need to check the settings for that user to make sure the rights are set correctly so that they can create a database.

0

Are you logged in as "root"? If you are, you might need to check the settings for that user to make sure the rights are set correctly so that they can create a database.

I am sure I am logged in as the root. How do I check if I am?

0

Okay so I have to create a new password but for some odd reason I am seeing an error (again) on the security page (xampp). It said something was wrong with the htdocs on line 100. What do I do? My max execution time has been increased to 60 seconds (originally 30) and in the htdocs (on line 100) i see that it is the ftp connect.

Anyone know what I have to do... i am a bit lost.

1

I'm lost too, I have xampp installed with none of those problems. Did you by chance change something and bork the install some how? Maybe it would be better to remove it all completely and do a fresh install?

0

I never did anything to it. other than increase the max execution time to 60. any clues?

1

One of the things I am confused about is the htdocs error, that is a directory. What file are you checking a line number in?

0

It opens a security.php and says there is an error on line 100.j

1

@micheal

Do this:

Open the XAMPP Control Panel.

Now you see Apache then click on Admin.

It will bring you to this page: XAMMP for Windows

Then you see on your left nav-bar Status and Security.

Click on the both of them.

Then tell us do you have any read green or red mark or just a post the image of Status page and Security page.

So we can see what requirement on those page that you need to do.

Edited by LastMitch: grammer

1

You must mean this page https://localhost/security/index.php

You're going to need to provide the exact error message that you're seeing.

I would strong consider removing and re-installing. You're having a lot of problems for just installing and not changing anything, and it sounds like to me the install is corrupted in some way.

0

Okay... the exact error message is this:
Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\security\htdocs\security.php on line 100

Any clues? I don't plan on un-installing (I actually don't know how to even do that).

1

After you made that change to your php.ini file, did you stop and start the server again?

You can check the phpinfo from the xampp control panel, to see if it reflects in there the correct value that you set it to.

Edited by pixelsoul

0

Well I restarted the server and I saved the changes to the php.ini... not much after that.

1

So, does the value in the phpinfo for max_execution_time show the correct value? And you should make the change and save it THEN restart the server ;-)

I need to go to bed here in a minute, just an FYI in case I don't respond right away.

Edited by pixelsoul

0

This is what I put:
;max_execution_time = 60

Am I suppose to have that semicolon in the beginning?

Edited by <M/>

0

actually it was never there... I just added here incase you thought I was weird about semicolons.

But I don't see anything wrong with "the code".

0

where do I look? there is a lot of lines of "code" on the page... where do I find it?

1

As pixelsoul suggested anything after comma is ignored .Check out http://php.net/manual/en/configuration.file.php

; any text on a line after an unquoted semicolon (;) is ignored
[php] ; section markers (text within square brackets) are also ignored

Make a simple program and print phpinfo() data.

<?php
echo phpinfo();
?>

Check if it is showing the change that you did in ini file

Edited by IIM

1

In MySQL creating a data source does not instantly make a user to go with it. You must clearly make the user and allow acess. I do not more about it, becuase I used phpmyadmin for just 1 month.

0

Sorry for responding so late, I didn't realize that there were unread comments here.

But anyways, I noticed something strange.

When I went to the database page in phpmyadmin, the "no privilige" message dissapeared. But when I refresh the page, the message is back.

Any idea why I can't get this thing working. I know I am logged in as the root and I am able to work with the .ini file. Any clues?

0

I increased the max execution time to 120, I still see the same error as before in the xampp/security.... I just don't know what to do.

1

I increased the max execution time to 120, I still see the same error as before in the xampp/security.... I just don't know what to do.

micheal, I'm a bit concern of how you are installing this. I mean you can't change php.ini file or other file like this.

You want your local host (XXAMP) have the same setting as Host Server (Internet).

What browser are you using?

Are you using Chrome? Try Firefox.

Edited by LastMitch: grammer

0

I am using Internet Explorer on windows 8. I am sure I installed this properly, I followed a video on youtube on how to install xampp on windows...

Edited by <M/>

1

I am using Internet Explorer on windows 8. I am sure I installed this properly, I followed a video on youtube on how to install xampp on windows...

@micheal I think I post this from my preivous post did you do this:

Open the XAMPP Control Panel.

Now you see Apache then click on Admin.

It will bring you to this page: XAMMP for Windows

Then you see on your left nav-bar Status and Security.

Click on the both of them.

Then tell us do you have any read green or red mark or just a post the image of Status page and Security page.

So we can see what requirement on those pages.

Edited by LastMitch: grammer

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.