0

Hi All,

I have been using a latest version of wamp daily for the last month on this PC and suddenly over the weekend it has stopped working.

I have tried the following:

I have restarted all services a number of times.
Restored back to earlier point on Friday when known working.
The Wamp icon is green
I can access PHPMyadmin
Wamp states server is online
Using long code structure <?php ?>
Using correct extention
no skype

Now I don't know why this has happend

Thanks in advance

David

Edited by davidjennings

2
Contributors
3
Replies
20
Views
3 Years
Discussion Span
Last Post by davidjennings
0

Hi pzuurveen, thanks for your reply, I type the full url i.e localhost/db/index.php

if I just click on it, the file will open in DW.

http://localhost/db/index.php revert to localhost/db/index.php

and displays the following:

<?php
//dummy data

/*if(isset($_POST['title'], $_POST['post'])){
$UserFullName = htmlentities($_POST['UserFullName']);
$UserEmail = htmlentities($_POST['UserEmail']);
$UserLastPassword = htmlentities($_POST['UserLastPassword']);
$UserActive = htmlentities($_POST['UserActive']);

}*/

$UserFullName='Sam Smith';
$UserEmail ='email@sams';
$UserLastPassword ='15 Nov 2013';
$UserName= 'Sam Smith';
$UserActive='1';
require_once 'classes/db.php';
function Users(){
    $users = DB::getInstance()->query('SELECT UserID, UserFullName, UserEmail, UserLastPassword, UserName, UserActive FROM Users');
        if ($users->count()){
            foreach ($users->results() as $user){
            echo $user->UserLastPassword." ".$user->UserName." ". $user->UserActive,'<br />';
            }
        }
}
Users();

function UserInsert($UserFullName,$UserEmail,$UserLastPassword,$UserName,$UserActive){
 $usersinserts = DB::getInstance()->affected_rows("INSERT INTO Users (UserFullName, UserEmail, UserLastPassword, UserName, UserActive) VALUES ('$UserFullName','$UserEmail','$UserLastPassword','$UserName','$UserActive'");
}
UserInsert($UserFullName,$UserEmail,$UserLastPassword,$UserName,$UserActive);



UserInsert();

Thanks

David

Edited by davidjennings

0

Ok solved reinstated a backup of all the files from Friday. Still not sure why it happend.

Thanks again

David

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.