0

Hello dear friends on daniweb.
i have a problem i have hotst package on 1and1.com now is 9 months.... i it is 6 months i try to install latest phpmyadmin but still i can't i don't know how
i had download phpMyAdmin-4.0.4-all-languages zip i unziped and i upluad on www.myadomainname.com/phpMyAdmin-4.0.4-all-languages
but i don't know how to configure... i have 3 database in my package when i access to www.myadomainname.com/phpMyAdmin-4.0.4-all-languages there is a phpmyadmin user interface who need password and username ... i put my data base user name and password but it don't work, i have contacted 1and1 suport center and never i had them help about it and decide today to post my problem here i hope you help me thank you.

4
Contributors
21
Replies
69
Views
3 Years
Discussion Span
Last Post by chrisschristou
Featured Replies
  • 1
    diafol 3,669   3 Years Ago

    Can you avoid running phpmyadmin from accessible docroot? It may be better to run from cPanel/Plesk only. Read More

  • 1
    cereal 1,419   3 Years Ago

    Follow these steps: * delete `config.inc.php` file; * under `www.myadomainname.com/phpMyAdmin-4.0.4-all-languages/` create the directory `config`; * change permissions of this new directory to 644 or, if it does not work, to 755; * then reload the setup page, the red message will disappear, after that just click on **Add new server** … Read More

  • 1
    cereal 1,419   3 Years Ago

    > Can you avoid running phpmyadmin from accessible docroot? It may be better to run from cPanel/Plesk only. Chris in addition to diafol's suggestion, if you can connect to the database from your localhost installation (XAAMP or WAMP), then install PHPMyAdmin in your computer, so you can manage it without … Read More

  • 1
    cereal 1,419   3 Years Ago

    > i contacted 1and1 support they told me it is not possible Ok, it means the database server accepts connections only from allowed IP, as your server IP, so it won't work from your PC. Regarding 755 and 644 these are system permissions, 644 equals to `read + write` for … Read More

  • 1
    cereal 1,419   3 Years Ago

    > it folder when you say directory??? right??? Yes :) Folder is the name of the graphical representation (the icon) of the directory. You can try with 777, but this is not the best setting, so: check if with 777 the error message disappears, then setup PHPMyAdmin, check if it … Read More

0

yes there is my problem their phpmyadmin is version 2 and it is hard to use it is not ergonomic it old hard to work with relation betwen table.... realy it is very different. :( you can't leave windows8 to go work with windows 98 !!!

0

Contact them, for security purposes you want the latest version of phpmyadmin etc.

Or move from 1&1. Only ever had bad experiences

0

Also, browse to the setup directory, you can use the wizard:

www.myadomainname.com/phpMyAdmin-4.0.4-all-languages/setup/

Before doing this, I suggest to change the name of phpMyAdmin-4.0.4-all-languages to something less predictable and searchable by the web spiders. Other information here:

0

yes i have contact more than 100000000 time i'm tired realy i want move fromm them but i don't know where to go .
i think it exist many way to securise the folder without rename it ;) .
thank cereal i'm on www.myadomainname.com/phpMyAdmin-4.0.4-all-languages/setup/
i read the guide from the site you give up i don't undestund all that
i created the file config.inc.php and i upluad it
on setup i have to message on this photo 94afd8abb3f6b86380382eaa7056a337

1

Can you avoid running phpmyadmin from accessible docroot? It may be better to run from cPanel/Plesk only.

1

Follow these steps:

  • delete config.inc.php file;
  • under www.myadomainname.com/phpMyAdmin-4.0.4-all-languages/ create the directory config;
  • change permissions of this new directory to 644 or, if it does not work, to 755;
  • then reload the setup page, the red message will disappear, after that just click on Add new server to insert the credentials to your databases.

Once you have finished remove the setup directory, otherwise anyone can browse there and change the settings.

1

Can you avoid running phpmyadmin from accessible docroot? It may be better to run from cPanel/Plesk only.

Chris in addition to diafol's suggestion, if you can connect to the database from your localhost installation (XAAMP or WAMP), then install PHPMyAdmin in your computer, so you can manage it without exposing your web space.

0

i have wamp it will be better to manage my database remotly in phpmyadmin on my pc bu i tried before to connect my database in mysqlworkbench but it din't work i contacted 1and1 support they told me it is not possible..... but how to do it in wamp??? maybe it is not possiible too (interstind i need your help to try it).
1.i deleted file confing.inc.php
2.i created user permission to www.mydomainame.com/phpMyAdmin-4.0.4-all-languages/config
i used user name and password i didn't see any suggetion for 644 or 7555.
3. i reload phpMyAdmin-4.0.4-all-languages/setup
still same error and when i try to create a server i get this error on photo

Attachments myadminerror.JPG 88.38 KB
1

i contacted 1and1 support they told me it is not possible

Ok, it means the database server accepts connections only from allowed IP, as your server IP, so it won't work from your PC.

Regarding 755 and 644 these are system permissions, 644 equals to read + write for the user that runs Apache (usually named www-data) and ownes the files in the server, if this does not work try with 755 that equals to read + write + execute.

If you're using Filezilla or another FTP client, right click the config folder and choose File Permissions, from there you can set the correct setting. Otherwise check the help center, I've found this:

It may be useful.

0

i created config folder in www.mydomainame.com/phpMyAdmin-4.0.4-all-languages/
it folder when you say directory??? right???
cause i have create permission in webspace explorer to 644 and 755 still i have the same error
i have try it in filezilla the permission is 755 but still same error what i do wrong????

1

it folder when you say directory??? right???

Yes :) Folder is the name of the graphical representation (the icon) of the directory. You can try with 777, but this is not the best setting, so: check if with 777 the error message disappears, then setup PHPMyAdmin, check if it works fine and then try to set config permissions back to 644.

Hope it works, I don't have other ideas.

0

still same :( in cpanel we have a option for protected directory to put user and password i'm going to do it maybe it work but it need 30 minute to save the configuration and will write if it work. :(

1

Ok, alternative solutions:

  • install on local, and create the config file, then upload it to the server;
  • manually create config.inc.php, I've created two generic connections.

Here's the template:

<?php
/*
 *  Generated configuration file
 *  Generated by: phpMyAdmin 4.1.0 setup script
 *  Date: Sat, 14 Dec 2013 22:12:01 +0100
 */

/* Servers configuration */
$i = 0;

/* Server: local1 [1] */
$i++;
$cfg['Servers'][$i]['verbose'] = 'local1';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = '';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'root';

/* Server: local2 [2] */
$i++;
$cfg['Servers'][$i]['verbose'] = 'local2';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = '';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'root';

/* End of servers configuration */

$cfg['blowfish_secret'] = 'place a very random string here'; # change this
$cfg['DefaultLang'] = 'en';
$cfg['ServerDefault'] = 1;
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
?>

Set your connections, upload it to /phpMyAdmin-4.0.4-all-languages/ and then remove setup and config directories. For more options check the PHPMyAdmin documentation linked in one of the previous posts.

0

it work with 755 thank you friend but don't leave now friend i nedd your help install with setup will be easy for me.
now i have only thsi message.
ac5c177e226f82031b8d8eb74a7b479f
i now what i do next???
i have just to create new server and what i put in required field
like : Verbose name of this server(A user-friendly description of this server. Leave blank to display the hostname instead)
AND Server hostname(Port on which MySQL server is listening, leave empty for default)
AND Server socket
AND server port
AND use ssl i mus yes or not ??
PHP extension to use mysql or mysqli ???

1

Good! Click on New Server then as:

  • Verbose name of this server: choose something of your choice, in my previous example, the name were local1 and local2, this is related only to PHPMyAdmin;
  • Server hostname: is the same hostname you use in your scripts to connect to the database, so it can be something like an IP, it can be localhost or a domain name as db001.oneandone.com;
  • Server port: the default listening port for MySQL servers is 3306, so you can leave it blank, if you have another setting then fill the field;
  • Server socket: this is a file in the filesystem, it's used when the database is in the same box of the web server, in practice the socket overrides the network layer and gives much speed between the server and the web application, I don't know if you can use it with your current hosting plan, I don't have experience with 1and1;
  • Use SSL: as the previous it depends on your configuration, if your plan provides SSL connection to the database then use it, otherwise leave it empty;
  • Connection type: is used to switch between TCP (given by hostname:port) and socket connections, you'll probably need TCP;
  • PHP extension to use: if your current version of PHP supports MySQLi then select it, the requirements are MySQL 4.3.1 and PHP 5.*, if you have doubts create a file with phpinfo() inside to check your PHP configuration;

After you've done with this form, go to the Authentication tab and fill it with your database credentials (username and password). The best authentication type you could choose is signon but you can use cookie or http, just avoid config because it will store user and password in config.inc.php, check this for more information:

Once finished, click on Apply to save the forms, go back to the main page of setup (it should be overview) and you will see a list with the new configuration. At this point, click on Save, you should get this message:

Configuration saved.
Configuration saved to file config/config.inc.php in phpMyAdmin top level directory, copy it to top level one and delete directory config to use it.

So move the new file to the parent level, i.e. on /phpMyAdmin-4.0.4-all-languages/. You should also save the file in your computer for future changes.

Remember to remove config and setup. And that's all, it should work fine.

Edited by cereal

0

i think i have undestund everythink but in Authentification tab i use singon use my database username and password but in bottom there is 2 field require Signon session name and Signon URL
i had i idea for sigon and i created www.mydomainname.phpmyadmin-4.0.4-all-languages/signon/
and i must creat file sigon with script ??? or it create automatic
and what for session name and sig out url????
and i thank you again friend for your help it is very helpfull.

1

Ok, sorry for previous suggestions about the Authentication method, I was a bit asleep and I confused the options :D

So, if you don't use the config mode, do not fill username and password fields.

For now use cookie or http modes. In both cases, you do not need to fill anything else in those forms, there are some extra options, but you can skip them for now. With these modes you will get a form to insert the database credentials.

The signon method is used to unify the login, for example: you have a login script to access the admin pages, through this method you can start a session that gives you access also to PHPMyAdmin (PMA). Check examples/signon.php to see a demo script, this expects that your login credentials matches with the MySQL account, but you could encrypt them into a table and extract them when you start the session... anyway, this is a bit tricky and if you don't have special requirements go straight to the cookie or http methods.

0

it is the biggest help i never receive in my life from the day i started with php .. thank friend it work :) me too i was a bit asleep that time.
about security can rename the phpmyadmin-4.0.4-all-languages without problem??? or other security methode who will never bring my website visitor by mistake to www.mydomainname/phpmyadmin-4.0.4-all-languages ???

1

You're welcome, I'm glad it works all fine.

can rename the phpmyadmin-4.0.4-all-languages without problem???

You can rename it without any problems.

in cpanel we have a option for protected directory to put user and password

Do it. Most scanners will try to find /phpmyadmin-* or strings like /pma, /mysql, /db or /database so if you can add an extra layer it won't hurt.

Votes + Comments
help full thank so much friend
1

thank you so much if i post a problem i will send you a message for now you are real friend :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.