0

The scenario is like this:

  • I am using a CMS that uses FCKEditor (that's what came with it not CKEditor).
  • I use this CMS a lot, I'm pretty familiar with it and I have never had a problem on my machine or anyone else's using the Admin facility for the CMS. I don't believe that the CMS is the source of the problem or that it is matters much what CMS it is (and few people here are probably even familiar with it).
  • A copy of the CMS with the setup for a specific site is installed on a server. I use this web host a lot so I am pretty familiar with them and have not had any problems with them.
  • From my Win 7 (64 bit) machine, I can access this site and use the Admin facility with no problem. It gives you a WYSIWYG view of each web page with all of the FCKEditor icons along the top of the box.
  • From another Win 7 (64 bit) machine belonging to a client, running from the same site, the Admin facility does not provide a WYSIWYg display and the FCKEditor icons aren't displayed. There is a (small) box displayed that contains the html rather than the WYSIWYG display.
  • I tried it from a third Win 7 machine and everything displayed properly on that one as well.
  • I have looked on the Forum for the CMS, posted the problem there (no response) and looked on the internet at large (including the CKEditor site) for anything similar and I haven't found anything.
  • I had the client run a little program that checks if Javascript is active on her machine (in her browsers), thinking that having it disabled could possibly cause this. It said that JS was working fine (I tried it both ways on my machine before I gave it to her).
  • We tried this site on her machine using IE and Chrome. The result was slightly different but the bottom line was that it didn't work on either one.

I don't believe that anything is wrong on the server. It would seem that something isn't right on her machine but I am stumped in terms of what to look for or how to resolve it. I don't think that she would be very interested in the sledge hammer approach (reloading Windows etc).

I'm looking for ideas and inspiration as to what I can check that might be the cause of this.

Edited by chrishea

2
Contributors
2
Replies
11
Views
2 Years
Discussion Span
Last Post by chrishea
0

have the client check this site to see if the editor is working. Click Here

Have the client disabled all browser plugins or reinstall firefox or chorme. Also, check the asset paths.. Sometimes this is a problem for browsers if a FQDN is not placed in the asset path.

You can have the client install firefox, and install firebug plugin, and check if any errors or file assets are not loading correctly.

If you have a demo we can see or show the code for the page the editor is on, we might find something you missed.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.