I am having running the getProxy function from my server machine at work. I tried using the same code below from my server at home and it worked fine with no problems. Is there a setup option of some kind that I may be missing?

// Define needed parameters and put them in an array..
$parameters = array(
'v_state'             => 'NJ',
'v_city'             => 'Haledon',


);



// Define new object and specify location of wsdl file.
$soapclient             = new soapclient('http://www.test.com',true);


$proxy = $soapclient->getProxy();


$err = $soapclient->getError();
if ($err) {
// Display the error
$answer = 'Constructor error ' . $err;
} else {
// call the method and get the result.
/*      $result         = $soapclient->call('GetData',$parameters,'http://www.test.com');*/
$result = $proxy->GetData($parameters);



// Display the request and response
echo '<h2>Request</h2>';
echo '<pre>' . htmlspecialchars($proxy->request, ENT_QUOTES) . '</pre>';
echo '<h2>Response</h2>';
echo '<pre>' . htmlspecialchars($proxy->response, ENT_QUOTES) . '</pre>';

When I try to use the same code on my work machine server I am getting some weird error:

Parse error: parse error, unexpected T_STRING in /home/oracle/infr/lib/php/nusoap.php(6983) : eval()'d code on line 1


Fatal error: Cannot instantiate non-existent class: soap_proxy_484983192 in /home/oracle/infr/lib/php/nusoap.php(6985) : eval()'d code on line 1

im not sure why this error is occuring since i am using the same php classes as my server machine at home.

Any help would be greatly appreciated. Thanks.

Edited 3 Years Ago by happygeek: fixed formatting

Hello all,
After backtracking and looking through the nusoap classes. It seems like the true error has to do with access to the WSDL file. I printed out some echos and the error that occurs before anything else is the following: HTTP ERROR: Couldn't open socket connection to server http://www.test.asmx?WSDL.
Again, I am using the same nusoap classes as my home machine however the machine at work is receiving this time out error! Does anyone know if certain port has to be open? Or can there be a security issue at my job that my be blocking access the the server hosting the WSDL file? I thought we were just using regular http requests? Any help would be appreciated.

This article has been dead for over six months. Start a new discussion instead.