Hello
I am attempting to upload a backup (gzipped SQL), to my server via phpmyadmin but it is just over the max upload limit therefore I cant upload it!

How can I get around this.. is there another way of uploading the phpmyadmin gzipped backup, or changing that limit?

I am using plesk on linux on a VPS.

Thanks for your help

Sam England

IS there a direct backup/restore MySQL databases option in Plesk? If so, you should use that rather than phpmyadmin. I used CPanel and there was such an option to backup/restore MySQL databases without using phpmyadmin.

Also if you have ssh access, you could directly dump the mysql database using the mysql command after uploading the backup file to your server. This is the most reliable method.

Hello
I am attempting to upload a backup (gzipped SQL), to my server via phpmyadmin but it is just over the max upload limit therefore I cant upload it!

How can I get around this.. is there another way of uploading the phpmyadmin gzipped backup, or changing that limit?

I am using plesk on linux on a VPS.

Thanks for your help

Sam England

If you cant use SSH or Plesk doesn't have a backup from disk option, you can upload the gzipped file to your webserver, then decompress it using plesks filemanager (if it has that option) or you can decompress it first then upload.
Write a small php script that will read the mysql dump to the database. This avoids the lag in requesting the mysql dump over HTTP.
If your php script times out, you can edit php.ini and change the max_execution_time.
If you cant access php.ini then try setting it in your php script during runtime using the function:
void set_time_limit ( int seconds ) see: http://us2.php.net/set_time_limit

If you cant change the max_execution_time, then you should be able to split the mysql dump file into pieces. Each query is seperated by a semicolon and line break (\n) immediately after.

So you could probably seperate the file into say, 100 queries, and only run this set number each time you load the page.

This article has been dead for over six months. Start a new discussion instead.