I am using visual devloper express, and i have been following allow in the "starter videos". for lesson 8 (editing and insterting into a sql express db file on the local host), the example worked fine, but when i try to replicate the example with a SQL database (external one) when I am configuring the formView, and i try to click the advanced tab under 'Advanced SQL Generation Options", I do not have the abilty to check the 2 boxes for generate insert, update, delete statements, etc (they are greyed out).

i have an asp page that has the same connection as this page and i am able to insert a record, so i am sure it's not a permission thing...

does anyone else know how to solve this problem, or has it occured for someone else? I am at a loss....I don't understand what I am doing wrong here... a plain old asp coded page inserts records into this table in the same database, but I am unable to check the boxes for "generate insert" etrc, and the error I get on the page itself is

Inserting is not supported by data source 'SqlDataSource1' unless InsertCommand is specified.



Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NotSupportedException: Inserting is not supported by data source 'SqlDataSource1' unless InsertCommand is specified.

Did you set your id column as a primary key in the external database? This prevents the generate sql statements being available as it can't generate sql for tables that don't have a primary key.

THANK YOU SO MUCH!

I was going crazy and that solved my problem in less than 1 minute ;)

~ Andrea

This question has already been answered. Start a new discussion instead.