0

The 'Quick reply' and 'Go advanced' buttons on the quick reply form stopped working for me about a week ago, I thought it might be temporary/known about, but that's quite some time, and perhaps it is Opera specific. This is only on the quick reply form at the bottom on a thread, I experience no problems with the form on the full 'post new thread' page.

8
Contributors
33
Replies
34
Views
10 Years
Discussion Span
Last Post by longrun
0

Well. It's still not working; but I can tell you the problem is style/layout related rather than any problem with the buttons/form itself. Heres a description of the problem with more insight:

- Normally, buttons on Opera can be clicked ( really! ), the color of the button changes when a button can be clicked and/or has just been clicked.

- The buttons on the quick reply form however, don't get this anymore. When I mouse over them, they don't change color, when I click them, nothing happens. That activity is expected if a button is disabled, but these buttons aren't disabled; because:

- Opera has a mode to supress layout elements; when I enable this mode, the buttons can be clicked. This mode is not generally disabling style or anything else; just divs, tables, lists etc; so, the buttons themselves can't be disabled, because they work when this mode is on.

I would put forth as potential reasons: some hidden and click-absorbing layout element is over the buttons, or the buttons are in a disabled layout element, or Opera generally disagrees with some layout at that point in the page.

As I said, it is only recently that this has stopped working, but not immediately.

0

Try going into your control panel and disabling JavaScript elements towards the bottom of the options page and let me know if that fixes the problem.

0

Ah, that seems to have fixed it.

I guess I will leave the Javascript setting off for now, since I do use Quick Reply quite frequently.

0

Well the javascript setting alters a whole bunch of other things you may wish to keep enabled. I really had just wanted you to do it to help me debug this and figure out what is causing the problem.

Would you be able to do this for me: can you reenable the javascript but disable the wysiwyg editor? Thanks!

0

The buttons work when the basic editor is selected and with script enhancements enabled.

I have more info..

When the page is loaded, with script enahancements enabled and the wysiwyg editor chosen; For a few moments after the page is refreshed, the buttons are functional ( they change color on hover ); however, about 5-10 seconds after refreshing, all of the text on the page starts to vibrate for a while.. Seriously; the content of the page seems to grow and shrink, and repeat for about 1-2 seconds. Visually; any point of reference on the page vibrates up and down; then eventually stops. It is after this period that the buttons stop being clickable.

The growing and shrinking phase still happens when the wysiwyg editor is disabled and script enahancements enabled, but crucially: after that phase, the buttons continue to work. [[ The submit buttons are relatively 'higher' on the page with the basic editor than they would be with the wysiwyg editor - which might suggest them moving into and ending up in a position 'underneath' something invisible that only starts to exist at a certain height; or of course, this fact might be irrelevent. ]]

The growing and shrinking phase does not occur unless script enhancements are enabled.

0

I don't see it as the font changing size, although it could be in places.. most apparent visually is the page contents translating up and down.. on closer inspection though, objects are moving around slightly during that period; in the advertisement and user title/avatar blocks between posts - the small changes in height of each of these in rapid succession kinda accumulates towards the bottom of the page to give the 'vibrating' effect.

0

Gotcha. Can you please let me know if you can reproduce this in either IE or FireFox? Thanks!

0

I'm still working on the issue but it would be helpful if you could let me know whether the page no longer jumps.

0

Hm. As for the jumping in Opera - it is still occuring; and the submit buttons do not work whenever the wysiwyg editor is used in combination with the scripting option.
The problem does not occur atall in Firefox ( wysiwyg editor or otherwise ); there is no visible jumping phase in Firefox either.

0

It is a real shame daniweb doesn't work properly with opera. I really like that browser.

Like I siad, please let me know if it's now working. It *should* be fixed.

0

Well, it still jumps around a bit; but now the buttons continue to work afterwards ^_^

( note: that's with wysiwyg editor and scripting enhancements enabled, which means, the problem is gone )

0

Does it jump around on every page or just thread pages? Does it jump around when you click on a thread title to go to the top of a thread page or just when you use the latest post in thread buttons?

0

I see jumping on thread pages and user profile pages; the pale grey rounded-corner boxes at the top of a user profile change height twice every time the page is viewed.. all the grey boxes on thread pages change height aswel. On other pages; board view and the main page, I can't see any jumping/height changes.

The second question.. it happens on any thread page; my view is newest first.. i see a button for 'first unread': when I click that the height change in all grey boxes still seems to occur, although its not obvious because it's at the top of page; i.e. its only one visible height change. - at the bottom of the page though, all of the height changes are visible.

0

Can anyone else confirm this with the Opera web browser? Also, are you using the latest version? Thanks!

0

Oh, there's at least one jump on each blog page to... it's really not noticeable on any pages but thread view; unless consciously looking for it that is..

0

I am using version 9.10, the very latest stable version seems to be 9.24.. I will update right now and let you know if it's still occuring.

0

Yep, there is still jumping/re-sizing in those places when viewing the site using the Opera 9.24 release.

0

It all works fine, well, it does since Dani fixed the problem I was having with Quick reply and Advanced reply buttons... But; don't you Opera users see the jumping period? Make sure you have scripting enhancements turned on; then refresh this page and quickly scroll down to the quick reply box at the bottom.. Personally I don't see this as not working in any sense.. but.. it's certainly strange looking. I see it on this (Windows) Opera client and also on another Opera client on another Windows machine.

Strangely, it seems to be more powerful and continue for different lengths of time depending on the thread.. this thread for eg. http://www.daniweb.com/forums/thread88858.html is also a full-page of posts, but there seems to be visibly less jumping than there is when viewing this thread... maybe though, that's because there's more text and it takes longer for me to scroll to the bottom, thus causing me to miss the beginning of the jumping?

Anyway.. Dani; thankyou for fixing the Quick Reply problem. Personally don't mind the jumping.. I've got quite used to it now.

0

>Can anyone else confirm this with the Opera web browser? Also, are you using the latest version? Thanks!

I'm also experiencing this problem. In fact, Daniweb seems thoroughly broken with Opera. Here's a list of some of the problems (Opera on Linux of course):

1) Quick reply button doesn't work
2) All pages on daniweb seem to cache so I constantly have to reload the page
3) The pages are sometimes justified to the left or right
4) The pages take quite a while to load

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.