I posted one Scheme code to Legacy Languages, and noticed that the formating for Lisp style quoting (single single quote or back quote before) does not function. I know you have more urgent things to consider, but you could put it in your list, Dani.

Recommended Answers

All 3 Replies

The Legacy Languages forum doesn't have a specific language parser, so what you see is default coloration, and the quote operator is being parsed as a string rather than the Scheme quote operator. Obviously you can fix it by being explicit with (quote [...]) instead of '[...]. Unfortunately, introspectively looking at the code in a post to determine which parser to use is tricky at best.

Unfortunately half point of the excercise is to use ` quote for first time in my life as it lets you unquote and insert values in by prefixing with comma.

Line quotes with syntax specified in Markdown is unfortunately gone so that is not option for multilanguage forum. Better for the code is it looks strange, is to have it as plain text. So at least the format could be plain text in Legacy languages. Trying to use same formating for Cobol, Fortran, Haskel, Lisp-family and J is not anyway good way, as you surely understand.

I took out display quoting and made the circuit quoted with function form. I removed commented out lines. Still the coloring is strange, but at least better.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.