0

Site link: http://www.stmatthias.co.uk

Basically, what i find is that whenever i try to refresh any page on my site, it takes you to the index.php

There is also an issue that when i go on a page, say the about us page, it still says www.stmatthias.co.uk, instead of www.stmatthias.co.uk/about.php/

Any page entered in other than www.stmatthias.co.uk brings up the index page, and there is no custom 404 page which say if you type in www.stmatthias.co.uk/nonexistantpage.html comes up,

Thanks for your help,
Hope i made myself clear, not sure what i have done for this to happen,

4
Contributors
9
Replies
10
Views
5 Years
Discussion Span
Last Post by zobadof
0

Have you got some js to redirect ppl to the home page? Or maybe some server side member validation that locks visitors out until the "log in"?

Maybe your hosting provider has a permissions issue for your site, or you set one up and forgot. It could be a number of things that we, on this side cant tell.

0

Try commenting this section of js with a comment like so:

/*
<script src="js/login.js">
// Login Form
$(function() {
var button = $('#loginButton');
var box = $('#loginBox');
var form = $('#loginForm');
button.removeAttr('href');
button.mouseup(function(login) {
box.toggle();
button.toggleClass('active');
});
form.mouseup(function() {
return false;
});
$(this).mouseup(function(login) {
if(!($(login.target).parent('#loginButton').length > 0)) {
button.removeClass('active');
box.hide();
}
});
});
</script>
*/

and see what thats does.

0

Actually, thats not the cause at all. I think its the frameset you're using. All pages have the same URL if you click through the menu to your other pages. The URL stays the same. hmmm not sure what to tell you at this point.

0

its highly confusing, were are self hosting on a mac server, and im not sure what the settings are, ill take a look into the login as it may be a possibility.

0

I think the problem might be the frameset itself. It's src attribute is always set to "http://stmatthias.dnsalias.com" which retrieves the homepage. Regardless of whichever link you click, when the page loads it will come to the frameset part and retrieve the page pointed to by the src attribute.
So, i think if you really want to keep your frameset in your html, then in each of your .php pages, change the frameset src attribute to the respective php file.
eg. In about.php change the the frameset src to "about.php", etc
Try that and inform us.

0

I dont understand which part of the document is related to the frameset, i tried researching it but i am unsure.

0

Im using Chrome, i tried it in opera and IE9. Same issue in both. What are you using?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.