0

So I left for the summer this past summer, leaving my Toshiba Satellite sitting in my room (top floor of an un-ACed house in Vermont) for the summer. When I came back the battery was dead (wouldn't charge), so I bought a new one. Now when I try to turn on my computer, it usually turns the power light on for a couple seconds, and the "battery" and "wired power" LEDs on for a couple seconds, I can hear the CD drive start spinning, then it turns off. Usually, if I try enough it eventually gets to the Toshiba boot screen.

Also, when I try turning the computer off, or going into hibernate, it starts turning off, the hibernate bar goes like 99% of the way to the end, then it freezes. Same when I try to turn it off, which results in my having to turn it off by holding the power button. I was wondering if anyone could help me out and help me figure out what's wrong. Thanks.

3
Contributors
2
Replies
3
Views
10 Years
Discussion Span
Last Post by saintycon
0

I have a Toshiba Satellite L25-S121, after about one year, my battery started to really lose it's longevity. If it ran about 15 minutes, the battery indicator would beep and a minute later, shut down the computer. As nfox513 mentioned in a post 3 days ago, I did the same thing and bought a new battery. It charged one time I think, ran for about 2 hours. I was so thrilled. Next, I plugged everything back in, and now it will not hold a charge. The battery charge (far left amber light) indicator light will blink the entire time computer is turned on and plugged in. When I click on the battery charge meter on task bar of screen, it reads "0% remaining (charging)" as the progress. If I unplug power cord, computer shuts off immediately. I searched Toshiba site and cannot locate any kind of update BIOS for this problem, nor anything other than "step-charging" instructions. That does not help, because the computer shuts off right after being unplugged, within a second. What do I do? please reply here or feel free to email me at rob noell 3 at yahoo dot com with any tips you might have. Thanks very much!

0

I have a Toshiba Satellite L15 S104 and have the identical problem as listed above. I have had the computer for probably close to two years, the battery stopped charging, so I bought a new one. The new one charged a few times and ran fine, then all of the sudden refused to charge. I ran solely on outlet power for a few months but now it won't even power up that way! any help would be appreciated...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.