0

Hello all,

I cannot tell you when this started, as I do not use this machine too often, it is my laptop at home, and it is not used by anyone but me. I am thinking it is a viru/spyware or similar, but I am not sure about that either. Once or twice I think I got on the machine, found out it was not getting to a webpage and walked away, because I was looking for info, and not able to sit down and figure it out. I did have to download updates as well. Which it did, but it took a long time, I thought that was what was slowing it down/not keeping it from getting to a website.
Anyway, I have Google set as my homepage, so when I open a new page, it just spins, no Google, never gets to any other states than that. It just spins like its trying but gets nowhere. I pulled up a command prompt, and was able to ping www.google.com without loss. I ran AVG, and it didn't find any viruses. I also checked to make sure the AVG filtering webpages wasn't causing the trouble. I think I did that right

So, any help would be helpful. Again, I really cannot go out and download software to aid me, cause I cannot connect. I did copy the IP address of Google into the browser to see if that worked. It didn't.

Thanks,

Jim L

6
Contributors
17
Replies
46
Views
3 Years
Discussion Span
Last Post by kram7750
0

The question is can you get out of your computer and after that the thing to check is can you resolve any domain names. Try going to a command prompt and checking to see if you can ping your computers IP address then the gateway then try to resolve domain names.

ipconfig /all

Will give you the information you need to check these things.

nslookup google.com

If that does not come back with a IP address then you have problems with your DNS server.

0

Thanks for getting back to me, rch1231 and rubberman. Quickly, I am running IE, and I tried Firefox with no avail. SO, I can prob rule out an IE prob. I didn't thinkabout DNS. I am at work right now, the laptop is at home. I will check out the info above when I get back. Oh, I guess I could bring the laptop to work to see if I have the same problem. That would prove a home network prob vs. a laptop prob.

Thanks,

Jim

0

Couple of things... you either have a redirector malware which is just not good at its job, or, more likely, a failure of some of your system softwares involved in rendering pages. Me, I'd grab my installation dvd/cd and run in a command window:
sfc /scannow
That will replace any damaged system files.
Next, I would check my Winsock entries, and repair my TCP\IP configuration; this command will do both:
netsh int ip reset C:\resetlog.txt ..and place a log into your C: root.
Or maybe the other way about.... the netsh cmd is fast.
Restart, and try a webpage again.

0

K, I looked, DNS was set to automagic detect, I put in 8.8.8.8 and 8.8.4.4. Plus I did a ipconfig/flushdns. It was not working cause of the proper level admin, so I opened the window as Admin., ran the command, and I was able to get to Google, etc. So, thanks to all for the help.
THe next morning I checked it, and it was spinning again (not connecting to Google), so I did another flushdns, that seemed to do it.
Gerbil, you are right something must be causing something. I will take your advice and run with it. Now I can reach the webpage, I reference your info, and see if I can find the cause. Thanks.

Edited by jimfive

0

Argh, this has not been solved. It happens all the time, and flushing DNS is not doing it. I did notice that I cannot open .jpg files, but I can open .gifs. Isn't IE the primary way to view a .jpg? Could it be IE that is the problem? I will try again with Firefox, but now I think about it, I couldnt get Firefox to go, becuase it wants to download new versions (I don't use it), and it can't because it cannot connect to the internet. AVG wants to download the latest version to check for viruses, etc. and I cannot do that, because I cannot connect to the internet.
Annoying. Anyone have any clues?
Thanks, Jim

0

Press F8 during startup and select safe mode with networking and see if you can connect to the net. If you can connect, download Mbam (google will easily find it), update it and run a full scan and get it to remove all it finds.

Edited by Rik_

0

Rik, thanks, I'll make it happen, and take it from there.

0

Sumbitch, the notworking is just that. Very interesting. I did a DNSflush it seemed to work, but within a minute it was down again, I thought for sure something evil was redirecting. I will play with netsh, compute some stuff, and see what happens.

Edited by jimfive

0

I'm not sure why /flushdns helps unless the cache is corrupting quickly...? So look upon its contents first.... /displaydns

0

I did netsh and rebooted. Still the same problem. I pinged my IP, i pinged my gate, all good. I did an nslookup google.com and that worked. Actually it worked, timed out, and worked again (3 times in a row).
So, gerbil mentioned using: sfc /scannow
It sounds like I can do that from a command prompt. Do I need to do it from a boot disk, in which case, I put the disc in, boot up, and then get a command prompt, use:
sfc /scannow /offbootdir=f:\ /offwindir=c:\windows
where the CD/DVD drive is f:\?

Thanks,

Jimfive

0

Download hdtune with another computer and stick it on a usb and install it on the ailing machine. Run a full scan. If it finds bad sectors then your hard drive is faulty and needs to be replaced as you will never repair the software on it.
Every computer I get in the shop get's a hdtune scan. Saves a lot of time.

0

Downloaded the free version, will check it out this weekend. I have a modem from Optimum from there it goes to my network upstairs and network downstairs. THe downstairs network, goes to the laptop, and to the XBox360 and XBoxOne. I wonder if they are competingwith the laptop and that is the problem. THe laptop is using RJ45, not on wireless. It is DHCP.

THanks,

Jim

0

Okay, jim, so in there somewhere is a router. Just a silly check, but make sure that in its settings your compy is not excluded from its DNS service. You can do that on some models.

0

Hmm, you have a point, there could be some scramble in there. I have a note in my filesthat says, -=-=To avoid a conflict with your Internet Service Provider, your router's IP address has been updated to 10.0.0.1.
You must now update the IP addresses in your router's configuration settings for each relevant service,
such as port forwarding and IP address reservation.=-=-=, but now that I am thinking about it, when i do an ipconfig, i think it says my laptop's IP is 10.0.0.1. I will have to check that out.

0

That other is a router setting, not in your lappie.
...and check that your computername is correct. Netbios is picky about that.

Edited by gerbil

0

This post may be useless, but check the Hosts file: C:/Windows/System32/drivers/etc/hosts

Right click > Open with > Notepad. Check what's inside.
Sometimes viruses/malware/adware can use that file as a advantage to redirecting you to other malicious websites, or even blocking access to websites by displaying a blanc page. It's a good advantage for ad-blocking software, though.

Anyway, if there are URL's inside, select them all and delete. Ctrl + S to save. Try the webbrowser again (make sure to close it down and then try again). Don't delete the Hosts file, though.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.