0

I installed postfix + dovecot + sasl and so... this is the problem:

I try to send mail from telnet using AUTH LOGIN and it works perfectly sending to gmail and hotmail, then i configure outlook to work with the same account and it bounces back a message telling me im not allow to send mails that looks like this:

<xxxxxxxx@gmail.com>: host gmail-smtp-in.l.google.com[72.14.247.27] said:
550-5.7.1 [XXX.XXX.XXX.XXX] The IP you're using to send mail is not
authorized 550-5.7.1 to send email directly to our servers. Please use the
SMTP 550-5.7.1 relay at your service provider instead. Learn more at
550 5.7.1 http://mail.google.com/support/bin/answer.py?answer=10336
1si8196120agb.8 (in reply to end of DATA command)


I think i need to choose and option on outlook or configure someway that everytime i want to send a message it do something like AUTH LOGIN on telnet....
how can i solve that? thanks in advance

2
Contributors
10
Replies
11
Views
9 Years
Discussion Span
Last Post by vikonava
0

Hey There,

Two things you can try.

Can you make sure these entries, and file, exist - or add them if they don't:

echo 'pwcheck_method: saslauthd' > /etc/postfix/sasl/smtpd.conf
echo 'mech_list: plain login' >> /etc/postfix/sasl/smtpd.conf

You need to run the commands as root, I think, or they won't work.

Let me know if that helps.

Best wishes,

Mike

0

yup ive already had those entries and it still doesnt work... i checked again i have those entries and they are correctly :(... thats strange cause i telnet and do auth login and the smtp server works :(

0

Hmmm...

If you do

telnet localhost 25
ehlo localhost

do you have this line in your output (and could you post that)?

250-STARTTLS

I would have thought it was Outlook authentication setting, but if you can go direct to the IP, I'm wondering if it's a TLS handshake problem.

, Mike

0

yes mike, thank you... this is the full output of ehlo command:


250-vikonava.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

0

Man,

I'm at a loss, unless it's with Outlook. Is it set to have the outbound server use authentication and SSL (port 465)? Also, set it so that it doesn't hide the transmission details, like it does by default. I'm not sure how to do that off the top of my head and we use Lotus at work :(


Also, if that isn't the issue, could you post your main.cf?

Thanks :)

, Mike

0

im gonna send u details on PM :) see if you can get to help me

0

aparently im getting this...

unable to load Private Key
14674:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:644:Expecting: ANY PRIVATE KEY

0

looks like solved :) what i did was just changing the line that said cacert.pem to the created one smtp.key on the tutorial for Ubuntu Dapper Perfect Installation, thanks to Mike that solved this :)

0

my bad, i think its not solved :( still bouncing i think i send it from my other ouytlook account

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.