0

Hi, I'm super new to this website just want to this real quick.
Alright, I'm using knoppix live cd on my computer using it as a save disk. Orginally I had XP Pro SP2. It crashed a week or two ago. I shoved in the knoppix cd and saw my files. =]
I then began to go into my crashed master drive and I tried to drag the files into my perfect slave drive.
The problem is I couldn't it said something along the lines of I don't have permission. I have a feeling it has to do with the previous OS of Windows.
How do I take off the permission? I just want to drag and drop files from my crashed master into my slave.

2
Contributors
2
Replies
3
Views
11 Years
Discussion Span
Last Post by Smartedpanda
0

Several possibilities:

The hard drive is corrupted, and although the files are listed, Linux can't copy them because there's insufficient data. This could also attribute to why Windows XP crashed.

The slave drive isn't formatted/partitioned. In order for an operating system to store files on a hard disk, it must first have a filesystem. First of all, a partitioning program must create a usable partition. Then, it must be formatted. Lack of this will prevent file transfer to the slave drive.

The slave drive is formatted, but it's formatted to Microsoft's NTFS filesystem. Although Linux can read perfectly fine from this type of partition, support for writing to NTFS drives is nonexistent or not reliable enough to use. If you want to write data to a disk in this condition, you'll need to repartition/reformate the disk to something that Linux can read, such as ExtFS.

It might be a little bit difficult diagnosing which one is true, but here's what you can do: try copying a file from the damaged hard disk onto a floppy disk. If it works fine, then the problem lies with your slave drive and you should probably reformat/repartition it. If it fails with the same error message, then your hard disk is probably damaged, and you may want to bring it to a professional data recovery service if the data contained on your hard drive (or not) is valuable to you.

Hope this helps

0

Well, the slave is just a data storage. It doesn't have Windows installed. I just ended up burning CD's of my files. I couldn't burn DVD's but all good.
I believe you were right about how Linux couldn't correctly read the NTFS.
Note: I used
knoppix


Which isn't really fully Linux right? ;)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.