0

hi
i have an ubuntu 7.04 and nvidia card
i use nvidia-settings to change the resolution and then i save the conf to the file and it is so cool
the problem is whenever i restart my window manager (ctrl + alt + <-)
the screen resoltion comes back to the default
anyhelp plz

3
Contributors
8
Replies
9
Views
10 Years
Discussion Span
Last Post by w_3rabi
0

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Thu Nov 9 17:56:12 PST 2006

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "BenQ FP72E"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5500"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "1280x1024 +0+0; nvidia-auto-select +0+0; 1440x900 +0+0; 1280x768 +0+0; 800x600 +0+0; 640x480 +0+0; 1280x800 +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

0

OK. You need to edit your xorg.conf file, so open Terminal (I think it's located in Applications->Utilities).

At the prompt, enter the following:

sudo gedit /etc/X11/xorg.conf

This will open the xorg.conf file with read/write privileges. Now find the following section:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "1280x1024 +0+0; nvidia-auto-select +0+0; 1440x900 +0+0; 1280x768 +0+0; 800x600 +0+0; 640x480 +0+0; 1280x800 +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

And replace it with:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "1280x1024 +0+0; nvidia-auto-select +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Save and exit, and then restart X.

0

thnx alot for anyone helped here
i figured out that there is something in the
system->prefs.->screen resoltion
"make default ..."
i just checked it and it turned everythin ok
thnx alot again everybody

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.