Hello everyone.

I am running RedHat 9 in VMWare 4. Everything works fine, except for the Internet connection, which I can't configure.

I am connected to a home network, with two computers. I can access the Internet from this computer using Windows XP (my host OS), but it doesn't seem to work in RedHat. My ISP doesn't require authentication nor anything like that, as it is an always-on connection.

I have tried to string all eth0 files with the "check_link_down" function, and that made eth0 return a success message when I do "ifup eth0", instead of the "check cable" message I was getting. But still, the Internet doesn't work... What can I do?


Thanks in advance, from a newbie :)

Hello,

From the Linux environment, type in /sbin/ifconfig Let us know what you see.

Christian

More info on your network setup would help also:

- What make/model of NIC?

- Cable or DSL Internet access?

- Is there a router in the picture, or does the computer connect directly to your cable/dsl modem?

- Are you using DHCP or static IP assignment?

If you're using static IP addressing, check out some of the suggestions in this article:

http://www.stevewolfonline.com/Downloads/DMR/Doc/Linux/Network/NICConfig.txt

As I couldn't copy/paste the result, I took a screenshot.

[IMG]http://www.imageshosted.com/images/948338redhat_ifconf.jpg [/IMG]


As for DMR, I'm afraid I don't know what a NIC is... I'm using cable access; this computer connects to another one in my network; not sure: I know I get a different IP everytime I reset my modem :o

As I couldn't copy/paste the result, I took a screenshot... As for DMR, I'm afraid I don't know what a NIC is

Sorry- NIC = Network Interface Card; the network card in your computer (eth0).

Your screenshot shows the network card to be up and running, with what appears to be a valid IP and subnet mask. That's a good first sign.

I'm using cable access; this computer connects to another one in my network; not sure: I know I get a different IP everytime I reset my modem :o

OK- how exactly are the computers networked? Describe in detail how everything is physically wired together; it makes a difference in terms of what network settings you'll need use on the Linux box.

Thanks for your pacience.

As for my network details, it's not very complex: this laptop connects through a crossed-over ethernet cable into another ethernet port in the desktop. Once in the desktop, another ethernet port connects into the modem.

Just in case it's needed, the modem is currently USRobotics. I said currently because I'm expecting my ISP to send me a new one - they are upgrading their network.

Oh, I see- it's an Internet Connection Sharing setup with the Linux/XP laptop getting its Internet access through the desktop machine, yes?

If so, you should check (on the laptop) the TCP/IP settings that you have in XP's Local Area Conncetion properties, as you'll need to replicate those in Linux's configuration. The first thing to look for in the XP TCP/IP setup is:
is it set to obtain an IP address and DNS server addresses automatically, or is the IP information entered manually under the "Use the following..." options?

Let us know which way XP is configured, and if it's set up manually, please give us the IP/Gateway/subnet mask/DNS info that's entered there.

When I go to the "Support" separator of my connection Properties, I get this:

Address Type: Assigned by DHCP
IP Address: 192.168.0.75 (this one keeps changing, I think...)
Subnet Mask: 255.255.255.0
Default Gateway: 127.0.0.1

The above were returned in the laptop. Am I supposed to give you the desktop ones?


Thanks.

When I go to the "Support" separator of my connection Properties...

That description doesn't sound like you're looking at the standard Windows XP Local Area Connection properties in your Network Connection settings under the Start menu. Seems like you're looking at some vendor-provided connection utility instead.

I have to log off right now ("real life" work calls), but in the mean time can you look at (and post) the settings in the Win XP Local Area Connection properties please? I don't think the Gateway IP of 127.0.0.1 (the local loopback address) you gave is going to work in the Linux setup.

That description doesn't sound like you're looking at the standard Windows XP Local Area Connection properties in your Network Connection settings under the Start menu. Seems like you're looking at some vendor-provided connection utility instead.

I have to log off right now ("real life" work calls), but in the mean time can you look at (and post) the settings in the Win XP Local Area Connection properties please? I don't think the Gateway IP of 127.0.0.1 (the local loopback address) you gave is going to work in the Linux setup.

Hrm...

Additionally, you can open a command prompt in Windows and try ipconfig /all-- that should give detailed IP address, Gateway, and DNS information.

Hrm...

Additionally, you can open a command prompt in Windows and try ipconfig /all-- that should give detailed IP address, Gateway, and DNS information.

Oh, sure Alex- just give them the easy way out... :mrgreen:

Oh, sure Alex- just give them the easy way out... :mrgreen:

:p pfft! to you, good sir!

Just fresh on my mind because I had a customer type it into their box today...

Oh, great: you're upper-tier support for Dell, and "ipconfig /all" just came to your mind today....

Sheesh, no wonder I bought an IBM...

Tee :mrgreen: Hee :mrgreen: !

Anyone? I really need this for a school project...

Hello,

From the Linux environment, type in /sbin/ifconfig Let us know what you see.

Christian

When I type "/sbin/ifconfig", I get a dialog box that ask me do I want to save, or open appliaction.

Please help! Thanks

Are you typing that into your web browser!?!

Are you typing that into your web browser!?!

Ah... that would explain the dialog message, wouldn't it?

phate615,

What Christian (kc0arf) meant was that you should open a terminal window in Linux and type that command at the prompt. It's the equivalent to the "ipconfig /all" or "winipcfg" commands in Windows.

I am having the exact same problem with the exact same setup. Here's what I have done so far. I set up filesharing on the XP wireless card to share the conection with the ethernet. This set the ethernet with a fixed IP address. In the network setup menue in linux I made that the gateway adress and put it on the same subnet with the same mask.
Now I can ping my router and even pulled up google in my browser by IP adress. I still can't pull it up by URL though. The DNS server IP on the linux box is the same as the XP and my friends mac (They both appear to be using the wirleless router. I am pretty sure it's a DNS problem at this point but I don't know what the problem would be.
Maybe this will help with your setup problems (assuming I got this far doing it right) and maybe someone can help me figure out why I can't pull up URL's

I am having the exact same problem with the exact same setup. Here's what I have done so far. I set up filesharing on the XP wireless card to share the conection with the ethernet. This set the ethernet with a fixed IP address. In the network setup menue in linux I made that the gateway adress and put it on the same subnet with the same mask.
Now I can ping my router and even pulled up google in my browser by IP adress. I still can't pull it up by URL though. The DNS server IP on the linux box is the same as the XP and my friends mac (They both appear to be using the wirleless router. I am pretty sure it's a DNS problem at this point but I don't know what the problem would be.
Maybe this will help with your setup problems (assuming I got this far doing it right) and maybe someone can help me figure out why I can't pull up URL's

Based on the first few sentences in the 2nd paragraph, I am a little confused.

Your router should have a static ip address, in one of the following ranges:
192.168.*
10.0.*

Now, it should also end with a .1 if you haven't changed anything. For the example below, lets just pretend the router is 192.168.0.1.

On the linux box, type route -n, you should end up with something like the following:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.240.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0


If you don't see the last line (with UG under the flags), then the routeing is setup incorrectly. You can remove the current default route with the following command:
route del default

Then add the default route back the router using this command:
route add default gw 192.168.0.1


Once this is added, you should be able to ping out, if you can't you might want to check the configuration on the router to ensure that you have access to route packets through it.
(Some routers require that you use their DHCP Lease in order to route traffic, but this is very rare)