0

I'm having trouble running RH9 on VMWare. My host is Windows XP pro. I can install RH9, but I can't get it to run X window. VMWare doesn't give much help. I'm a newbie, and I'd appreciate it if someone could give me a fairly detailed, easy walkthrough on how to do this.

7
Contributors
12
Replies
13
Views
14 Years
Discussion Span
Last Post by jaywave
0

What happens when you type "startx" in the terminal. Does the X server fail?

If you just can't run X but you can run console, it's most likely related to your XFree86 setup as opposed to a VMWare problem.

Check vmware.com to see the specs for the video card that is emulated.

-1

yup, its up and running. Now I just have to find a way to get internet running. i tried using bridged networking, and pretty much all the other options, but for some reason, it can't use my ethernet card

0

What problem with your nic card is there? I was having a problem with VMWare 3 and my network card because it's actually a linksys gigabit but vmware emulates it as a regular 10mbit connection only. VMWare 4 fixed the problem.

In addition, an old problem I used to have was I used bridged networking with a Linux host and Win2K vm, with no problems. However, when I put WinMe in a virtual machine, same host, same networking setup, it would work for the first two minutes, and then I'd lose internet access permanently until I restarted the virtual machine.

0

Lol glad to hear it works for ya! I thought RH9 wouldent work so I installed Mandrake 8 instead. Dont really know whats the diff though since both run the same desktop shelll? I'll go try to look for answers now and come back with the results!

0

How did you manage to get Red Hat 9 working on VMware 4? Could you install VM tools? i couldent so the Xwindows performance was terrible. So i decided to use Mandrake 8.0 which is supported and it runs very nicely. However, I too have NO CLUE as to how to set up the networking to work in linux :( I desperately need to do this as I want to be able to xterm into a remote host to do work. ANyone has any ideas?

* weird thing is that during the linux boot sequence, it says that it FAILED to start up "eth 0" does that happen to you too?

0

I'm not sure this is related to your problem, but Vmware seems a bit funky when it comes to dhcp, at least that's my experience with VM4 and redhat 9.0. If you are also trying to use dhcp to no avail, then do a search on VMware.com's knowledgebase, and you will pull up an article that will give you help.

That's one of the main (albeit few) problems I've seen with using vmware; you never know if a quarky guest problem is contributed solely to the OS/hardware, or if its a vmware thing. This holds especially true when it comes to networking, since vmware networking is a mystery to me (take a hard look at NAT and advanced networks sometime and you will see my point).

-1

Im just almost completely lost as to where to start looking to fix the network troubles.

0

Trying to use dhcp to get an ipaddress? VMware4 + redhat9 (not supported atm btw) has a problem with that, which is why you have to do some fiddling with a few network files to make it work. Go to vmware.com, support, then do search for "dhcp" and you will get the instructions...i promise. Also, I assume you are using bridged networking...

Give us details about your setup, and we can perhaps narrow down the problem :)

Regarding the tools problem, its also something that is been high discussed in the vmware news groups...check the linux newsgroup (forget the address, check on the vmware site) for details on that. Has something to do with installing the source file for your present kernal. At least thats the problem I had!

Sheesh, makes me realize what a pain-in-the-ass vm4 + RH9 was to get set up! on the bright side, its been working great since then :D

-1

i am have tried this as well and have not been successful.
i can not even get the red hat to install, it gets to about 90% of disk 2 and falls over, keeps prompting me to insert the disk again and again requesting the same file which works fine as i installed it on a seperate machine, so it is something with vmware.

any ideas ???

0

To resolve the CD reading issue, you just first image the 2nd Red Hat CD to an ISO image, then mount that ISO image as the D: drive. That did it for me.

0

Quote:Has something to do with installing the source file for your present kernal.

I have the same prob using Linux 9 as VM that couldn't detect the dhcp. CAn any1 tell me how to resolve the prob related to the source file. I have checked the support of the VMware , but not working....

Many thanks
Jay

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.