0

Hello.

I'm sorry, I mistake the place to post replies. But I'm on the way now.

I was saying that I just read your "How to Configure Samba on RedHat Linux" tutorial.
I configured my samba server and I could connect my shared folder on localhost.

But here is the problem: When I navigate through network neighborhood in my Windows XP pro box, I can see the samba PC but, when I open it, I get an error message. It says that I have a duplicate name on the network. Look:

---------
\\localhost is not accessible.You might not have permission to use this network
resource. contact the administrator.......

You were not connected because a duplicate name exists on the network. Go to
System in Control Pael to change computer name and try again.
---------

It can be possible another Linux PC in the network has already that name.
Anyway, I should be able to change the name of my computer in the network.
Do you know what is gonig on?

Thanks in advance

3
Contributors
11
Replies
13
Views
13 Years
Discussion Span
Last Post by DMR
0

The name "localhost" has a special meaning in TCP/IP networking- it is an alias to the local loopback device IP of 127.0.0.1, which is present on any machine running TCP/IP regardless of operating system. As such, "localhost" should never be used as the actual computer name/hostname for any machine on a network, because it causes exactly the conflict you're experiencing.

If any computer on your network is using "localhost" as its hostname, you need to change that name to something unique.

0

OK

So, I can think that the only I need to do is to change the name from 'localhost' to another one to identify my PC over the network and, -in theory- it should work, right?

I'm using Red Hat. Can you tell me how / where can I change it?

0

To set the machine's host name in Redhat, you can do one of two things:

A) In the /etc directory you might find a file named HOSTNAME (if you don't, just create the file). It should contain a single line containing the hostname.

B) In your /etc/sysconfig/network file, enter the hostname after the equal sign on the "HOSTNAME=" line.

0

Ok, I did it.

But now I have another question.
Before change /etc/sysconfig/network I was working at 'localhost'.

When I changed the name, I couldn't open localhost (nither 127.0.0.1), of course because I just changed it .

If I write the new name I just put into /etc/sysconfig/network I only get an error msg.

What can I do in order to work again in localhost?

Thanks in advance

0

OK- try this:

Open your /etc/hosts file in a text editor and do the following:

Change the line that reads something similar to:

127.0.0.1 localhost.localdomain localhost

to:

127.0.0.1 localhost.localdomain localhost put_your_new_hostname_here

For example, if you chose a hostname of "linuxbox", the entry would read:

127.0.0.1 localhost.localdomain localhost linuxbox

0

Hi.

I did that.
In fact, When I'm using a console I can see in the prompt, the name I put under /etc/hosts

but the problem now is that I cannot see my 'localhost', ,i get the next error msg.

Socket Error

Connection refused by Remote Host

what can I do now?

thanx DMR

0

Sorry- I should have asked this before: are you assigning your IP info to each of your machines manually, or do you have a device (a router perhaps) acting as a DHCP server for your network? Issues of hostname problems vary depending on which addressing scheme you use.

0

I fussed around with localhost network settings for a few hours and then just started the smb service and it worked.

0

I fussed around with localhost network settings for a few hours and then just started the smb service and it worked.

And so you dug up a 1 1/2 year old thread just to let us know? :mrgreen:

0

And so you dug up a 1 1/2 year old thread just to let us know? :mrgreen:

Actually it was two things:
1. starting the smb server and
2. adding these lines to the iptables file (got this one here: http://www.linuxquestions.org/questions/showthread.php?t=5656)

I got sidetracked because "localhost" was showing up in windows and I thought windows was compaining because it didn't like the name "localhost".

I'm putting this here so that when I have this problem again, it might only take 15 minutes instead of 2 hours to fix it... :)

0

I got sidetracked because "localhost" was showing up in windows and I thought windows was compaining because it didn't like the name "localhost".

You're right- any computer (regardless of OS) running the TCP/IP protocol uses the local loopback IP address of 127.0.0.1, which is traditionally aliased to the name "localhost".
Given that, the net effect (no pun intended) of using "localhost" as a computer's network hostname can cause about the same amount of confusion as filling a room with a bunch of guys all named Bob Smith and then trying to do a roll call.

I'm putting this here so that when I have this problem again, it might only take 15 minutes instead of 2 hours to fix it... :)

lol- good future planning...

BTW- welcome to DaniWeb! :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.