0

Hi,

I cant save any php file into www. Gives permission error in text editor. But, i can save with using sudo nano ..... in terminal. In the properties of www directory, it permites only root.
How do i solve this problem?

Thanks

4
Contributors
9
Replies
10
Views
9 Years
Discussion Span
Last Post by lio04
0

Hi,

I cant save any php file into www. Gives permission error in text editor. But, i can save with using sudo nano ..... in terminal. In the properties of www directory, it permites only root.
How do i solve this problem?

Thanks

Thats because of the file permission system of Linux. It allows only root to write to the www folder because most probably the owner of that directory is root and the permissions for that folder will be 755.

To just allow your user to write to that folder you could do : -

  1. Make the owner of the "www" directory your user, by using the chown command.
  2. Set the permissions of the folder "www" to 757 using chmod command. But this would be a security hazard since anyone and everyone will then be allowed to write to that folder.

And if you wish to know how to use the commands theres always the man <command-name> or info <command-name> to assist.

To get a more in depth understanding of Linux file permissions you can go here.

0

When you say "But this would be a security hazard since anyone and everyone will then be allowed to write to that folder.
", do you mean anyone on the Internet because, i am using this at home and only access to the Internet.

Also when i do

Chmod 757 /var/www/

it generates an error which says "bash : Chmod command not found". i am in terminal.

0

When you say "But this would be a security hazard since anyone and everyone will then be allowed to write to that folder.
", do you mean anyone on the Internet because, i am using this at home and only access to the Internet.

Also when i do

Chmod 757 /var/www/

it generates an error which says "bash : Chmod command not found". i am in terminal.

Well all you had to do was just copy paste the command from my post. But I still suggest rather than changing the permission to 757, you change the owner of the folder "www" to the one you are using.
If you are just using it at home then I guess it wouldn't be too much of a problem (as long as you do not have a static IP address), but according to me its always best to follow the safer practice everywhere especially if it doesn't take too much effort from your side.

0

Ok. In the properties of www directory, it permites only root and it is not enabled. Also, there is not other option to let me add my user. How do i do it?

0

Ok. In the properties of www directory, it permites only root and it is not enabled. Also, there is not other option to let me add my user. How do i do it?

you need to run the chmod command or the chown as root, or using sudo whichever is more viable option for you. Also needless to say, it has to be done in the terminal and cannot be modified via the GUI. (Unless your distribution permits the root user to login via the GUI)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.