Heya,

I want to install TuxPaint on OpenSolaris.

I tried to install it by source, but it got stuck on the 'make' command. Can anyone please give the step-by-step process of doing that?

I am using the latest version of OpenSolaris.

Here's the install documentation for TuxPaint:
http://www.tuxpaint.org/docs/INSTALL.txt

Assuming you meet all the requirements described in that document, your next step is to post the error messages you encountered when trying to compile it.

I get the following error while running make -

make: Fatal error in reader: Makefile, line 13: Unexpected end of line seen

How do I resolve this?

This issue is specific to Solaris and appears to have been solved by editing the makefile:

For TuxPaint I did have to modify the Makefile to include: ARCH_LINKS=-L/usr/sfw/lib -R/usr/sfw/lib -lpng -lstdc++

(source)

This isn't working for OpenSolaris, the library structure is apparently different. Please help me with this, as I m new to installing applications by source.

I tried running 'make' again, this time not logged in as root.

It threw up many errors in the 'tuxpaint.c' file, then finally stopped at:

make: *** [obj/tuxpaint.o] Error 1

How do I rectify this?