when i installed suse on my laptop, i also installed both kde and gnome. when it boots up it automaticly boots with kde. how can i change it to gnome

First, let me say I wouldn't suggest this. If, for some reason, X gets messed up, you'll have a horrible time getting back into your system to fix it because the login manager will keep restarting.

But, if you're sure you want to do this, you can either set it up during install or do it afterwards using the setup utility. As root (this means you need to type su - root at a terminal prompt), type setup and hit enter. Go to the X Configuration section and hit enter. Go through the screens, and make sure to test your settings before choosing to have X start automatically (which is the last question it will ask you). Once you've finished that process, reboot, and you should have a lovely login manager right there waiting for you to log in.

There's a second way to do this, depending on the WM that starts up.
Usually, you'll see something like an options (or preferences) menu when you login. In most cases, you can change your Window Manager there.
Personally, though, I don't recommend going from KDE to Gnome, as Gnome has fewer applications developed under gnome2 right now, and it's just not as decent as KDE is and has been for the past few years. I guess that's all personal preference though ;)

Use yast to change the window manager