0

I have my FTP server set up and I created a user called ftpsecure and added the name to the list of users in vsftpd.conf. I type in the IP in my Web Development studio and the username and password. It connects and displays my FTP welcome message but then denies my access. Could anyone give me any help? If you would like me to I can post my vsftpd.conf file.

2
Contributors
9
Replies
10
Views
7 Years
Discussion Span
Last Post by rch1231
0

Check the vsftpd log file to see why it is loging you off.
/var/log/xferlog

And did you restart vsftpd after making the changes?

0

I just tried that by opening it with VIM and its empty, theres nothing there.

And yes, I did restart vsftpd.

0

Wrong file, my msitake. xferlog is what has transferred on off the server. look in /var/log/secure and see what the connection and login are doing.

0

I don't see anything except for it says something about connection on ports 20 and 21 and then something about GNOME and ORBit. Whatever ORBit is. I don't think I use it.

0

Do you have a firewall or SELinux installed? If so make sure that port 21 is open for ftp. The port 21 entry in /var/log/secure can you post it (without the password)?

0

I have both installed. I checked my firewall settings and all FTP ports(20 and 21) are open. I don't believe I have another firewall anywhere. Here is the entry in /var/log/secure.

Aug  5 15:58:43 fuggles sshd[2010]: Server listening on 0.0.0.0 port 22.
Aug  5 15:58:43 fuggles sshd[2010]: Server listening on :: port 22.
Aug  5 16:01:06 fuggles gdm-session-worker[2441]: gnome-keyring-daemon: couldn't lookup keyring component setting: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Not running within active session)gnome-keyring-daemon: couldn't lookup ssh component setting: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Not running within active session)gnome-keyring-daemon: couldn't lookup pkcs11 component setting: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Not running within active session)
0

Have you tried using a simple ftp in from a command line client and see if you connect? From either windows command prompt of linux shell

ftp <IP Address>

should prompt you for user name and then password.

0

I tried it on my Windows machine(which is what I want to connect from anyway). Here is how it went, they are on the same network over my router.

usr>ftp 192.168.0.198
ftp>User: ftpsecure
530 Permission denied.
Login failed.
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.