0

When I plug in my headphone, the speaker still sounds, how to solve this problem please, I can use alsamixer to adjust the total volume, but I just want the speaker stopped making sound after I plug in my headphone...Thanks for helping...:-)

3
Contributors
3
Replies
4
Views
6 Years
Discussion Span
Last Post by dspjm
0

Not sure if it's any help, but I had a similar problem with my old tablet pc.

Turned out that the main speakers and the headphones were on different channels. I eventually realised when I took a look at the user options/settings for the mixer and found (and enabled) a couple of extra sliders. So now I've muted the channel for the main speakers, turned the headphones to full and I use the master volume slider to control the overall volume.

So you might want to look into the possibility that your headphones and speakers are on different channels!

0

What distribution+version of linux are you running? Newer systems use Pulse Audio (as well as ALSA), which should allow you to change your output hardware from speakers to the headphone port.

0

I have found an answer, just ajust the alsamixer

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.