I've just installed Ubuntu Linux on my Packard Bell i3 PC which is great, except that now I have to develop stuff in Java [Android, no groans please]. I've used and developed in Linux a long time ago, but I can't seem top find anything that can open and close the DVD drive, which doesn't have any hardware controls. Can anyone help. Simple answers please. I've got enough on my hands getting used to Bash all over again, and Java [Way prefer c++]


Recommended Answers

All 6 Replies

#open tray

#close tray
eject -t

May need drive name appended.

Before I go on and I know I should have said all this to begin with. I'm running a dual boot system with Ubuntu Linux 10.10 [64bit] and Window 7 [64Bit] home premium. The machine is a Packard Bell i3 with 3Gb of ram, and 500Gb HD, there's an internal audio Relteck hardware, but I'm using an external USB Roland UA 25EX interface . the Linux install is using a GNOME Terminal [2.32.0 running a bash shell].

First off

#open tray

#close tray
eject -t

Doesn't work at all, though I haven tried it in a z-shell which is what I'm amusing this was written for.

There are devices/file descriptors in /dev

But I can't open or mount them

I'm assuming that I can't mount any of these because there's no media to mount in the drive. However the drive doesn't show up as a device in the list of availing devices. Like I said I've written code in Linux and UNIX [Solaris & HPUX] but that was quite a while back. I've still got all the reference books [which I'm plowing through to find a solution] but I really need to solve this one quickly as I've installed this as a development environment [The last time I tried developing cross platform on win 7 it crashed on me and I lost a lot of code]. I need the DVDR device to backup project code [Hard lesson finally learned, even though I used to bollock people for not doing it at work, yest, I'm a hypocrite].

Any help would be really gratefully received. If I'm not following the posting guidelines then I really apologies. I'm up to my eyes in problems right now and though I've skimmed through the guidelines, I haven't really sat down and read them completely [which I do intend to do as soon as I have some spare time].

OK, forgot I need to run it as root, thought you where using a z-hell :)

$ sudo su
# open tray
# eject

works totally fine.


Sorry, not quite used to this system yet, didn't mean to repost it, I'll read the posting guide really soon, promise, and thanx again

I actually don't need to be root user to do it. You may have to add yourself to the user group for the CD drive.

Thanx dude. I'll give it a go :)

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.