vectro 0 Junior Poster in Training

This is partially in reference to these threads:

http://forums.cpanel.net/f5/fastcgi-fcgid-php-ini-per-user-100133.html
http://forums.cpanel.net/f5/individual-php-ini-files-php-fcgi-php-cgi-160398.html

I more or less followed the instructions there and I came up with the following settings:

/home/username/public_html/cgi-bin/php.fcgi

#!/bin/sh
export PHP_FCGI_CHILDREN=1
export PHP_FCGI_MAX_REQUESTS=10
exec /usr/local/cpanel/cgi-sys/php5

/usr/local/apache/conf/userdata/std/2/username/custom.conf

AddHandler php5-fastcgi .php
Action php5-fastcgi /cgi-bin/php.fcgi

/usr/local/apache/conf/includes/pre_virtualhost_2.conf

Action php5-fastcgi /cgi-bin/php.fcgi
AddType application/x-httpd-php .php

The custom php.ini is placed in /home/username/public_html/cgi-bin/

When I implement this, the site shows error code 500. It appears it is being isolated to its own PHP configuration, because none of the other sites on the server seem to have a bad reaction. However, it won't load and there is no PHP error_log file with any data. Error logging is enabled for the custom PHP configuration. Even when it's temporarily enabled on the server's main PHP configuration it still shows no data. The Apache log shows this error:

[Thu Jan 05 11:10:22 2012] [error] [client {IP-REMOVED}] Premature end of script headers: php.fcgi, referer: http://www.{URL-REMOVED}

Does anyone have any advice on how to resolve this?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.