0

When I use username@ipaddress everthing works frine, but when I try to use username@computername I got nothing. It would really be a lot easier to use the computer/server name rather than walk over to the other machine and check the ip evertime. Any ideas? From everything I've read username@computername should work just fine.

3
Contributors
5
Replies
7
Views
5 Years
Discussion Span
Last Post by JorgeM
0

To me this sounds more like a DNS issue than a ssh issue.

If you don't have a dns server on your private LAN with the proper records entered then you will have to use the IP address. You can also define all of the PCs on your LAN in each PCs /etc/hosts file but if you have more than a couple machines this becomes a pain.

One of the best books available for linux networking is available for free at http://tldp.org/LDP/nag2/nag2.pdf

If you have DNS or your etc hosts setup correctly there shouldn't be an issue.

PS:
In windows you can also add to a hosts file in C:\Windows\System32\drivers\etc for windows 7.

0

keep in mind that its not username@computername, its username@hostname. the reason why I am making this distinction is because the host name is a fully qualified DNS name, not just a computer name. For example, this string user1@Server1 is not the same as user1@Server1.domain.com.

If you are fully qualifying the hostname then follow androtheos' suggestions.

0

If dns and/or the etc hosts file is setup with aliases, computer names should also work just fine.

0

My home network is mixed between Windows and Linux computers and I'M assuming that most of these setting are controled by out netgear wireless router.

0

Some of the wireless routers keep a table of computer names that they "learn" about on the network to help with internal name resolution. In the case of external name resolution, yes, your router running the DNS proxy service should take care of that without any issues.

A simple test would be to open up a command prompt and use the NSLOOKUP tool. See if you can resolve the host name that you are including in the username@computername string.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.