0

So I just got a new laptop, it was originally running 64bit windows 8 so i had to get rid of it.
Daft question, but I put a 32bit linux os (Elementary OS) on my system and it is running hideously slow.

I'm hoping it is just that I've put the wrong bit version on and the 64bit version of the OS would be better?

So the questions is why the difference? I thought you could use a 32bit os on a 64bit system without any speed issues. Or could it be a driver support issue?

5
Contributors
25
Replies
120
Views
3 Years
Discussion Span
Last Post by iamthwee
Featured Replies
  • 1

    64-bit system? Run a 64-bit OS. Yes, 64-bit pointers in your software take more space, but not enought to make any significant difference. In any case, your system can take better advantage of available memory, and swap (virtual memory) space, and will perform better since the CPU is designed to … Read More

  • > It's odd that you say Kubuntu is faster than gnome. I always thought gnome was leaner that kde? I know, it's weird, but it's my impression in general. I know that KDE is "heavier" (i.e., more RAM usage, a bit longer start-up time), and it's still a bit heavier … Read More

0

Depending on your amount of ram this can make a big difference. I had a similar experience with a windows laptop which had >4 GB ram. Everything above this amount could not be used by the 32bit version of the operating system. This meant changing over to the 64bit version allowed me to use the full 8GB of ram which offcourse makes a very big increase in speed. I have to admit that i don't know if it's the same for linux but i would assume so. This might be the reason your system seems to run slower.

1

64-bit system? Run a 64-bit OS. Yes, 64-bit pointers in your software take more space, but not enought to make any significant difference. In any case, your system can take better advantage of available memory, and swap (virtual memory) space, and will perform better since the CPU is designed to handle 64-bit operations more efficiently. In such a case, smaller is NOT better! :-)

0

Thanks, I'm gonna flash the 64bit os today when I get get time and then try it. Fingers crossed. According to the specs I've got 4GB of ram with a dual core 1.0Ghz processor but with a better onboard graphics card.

Edited by iamthwee

0

Well it still feels very sluggish, there doesn't seem to be that much difference. Perhaps I'll go with an Xbuntu 64bit install.

0

I have to give it up (elementary os) it is just not liking this new laptop. I suspect it might even be a graphics driver issue, I've got one of those fancy touch screen ones even though the damn thing is an ultrabook it is so small.

Bit peeved off, well Xubuntu it is. The only other thing I thought about was doing a system update from the software manager.

I read somewhere about updating the kernel and xserver xorg but I don't wanna go down that road.

Edited by iamthwee

0

Like rubberman said, if you have a 64bit system, run a 64bit OS. Basically, a 64bit CPU is made to use 64bit numbers and instruction sets. It will support the 32bit numbers and instruction sets, but it's like running in a "compatibility mode" or something like that. The point is, it's not "native" or "natural" for the CPU to run 32bit instructions. And also, an OS that is compiled to be optimized for a 64bit instruction set will be able to do more with less instructions or make use of modern extensions, making things faster overall. Finally, it could cause some issues, like mathijs said, with RAM memory and things like that. There was a brief period when some PCs were 32bit, yet had more than 4Gb of RAM (which requires more than 32bit to address), and that caused some issues. After that, 32bit OSes and CPUs implemented counter-measures to solve this problem, but I'm not sure that a 32bit OS running on a 64bit CPU would be able to use those counter-measures, and thus, weirdly enough, the issue would re-surface... but anyways, this is mostly speculation on my part. Long story short, you really should use a 64bit OS for your 64bit system.

Well it still feels very sluggish, there doesn't seem to be that much difference. Perhaps I'll go with an Xbuntu 64bit install.

There must be something wrong. Make sure you have installed the "Additional Drivers.." from the menus. I suspect, like you said, that this is a graphics driver issue.

Anything that can run Windows 8 can certainly run the newest version of probably any Linux OS out there.

I have an old 7-year-old laptop, 1Gb RAM and dual-core 1.2GHz, and it runs the latest version of ElementaryOS with no real problem (it's a little sluggish here and there, but that's expected). Only the latest Ubuntu had trouble running on it. But Kubuntu, Fedora, and ElementaryOS all ran fine in their latest versions (well, a little while ago, when I tried a few of them out on it).

You should try a KDE based distro, like Kubuntu. They are usually very fast, compared to the Gnome stuff (which I always found to be a bit sluggish).

If you have a graphics card from Nvidia or AMD/ATI, you need to install the vendors' proprietary graphics drivers. Both of these companies provide Linux versions of their latest drivers, and installing them is not too bad. The open-source drivers ("nouveau" for nvidia) are just there to work for old nvidia / radeon cards, they don't work well for newer graphics cards.

I read somewhere about updating the kernel and xserver xorg but I don't wanna go down that road.

Don't do that. I did that once, and it was hell to fix later. If there is a specific bug that way have been fixed in an up-stream version of the kernel or Xserver, then find a distribution of Linux that is more up-stream than the one you are currently using. Fedora distributions tend to be more up-stream than Ubuntu distros when it comes to kernel and Xserver versions. Btw, ElementaryOS is very "down-stream" (aka "old") in comparison to the major distros.

0

Thanks, it probably is a driver issue. The thing is, the laptop is using an onboard graphics card so I don't know if it has any drivers. In any case a fresh install of xubuntu seemed to work quite well. It is speedy enough to use I just need to set it all up. And I'm using the 64bit os now.

Great now I can take it to coffee shops and chill without having to lug about a monster in the backpack.

0

If you don't know if you need additional drivers, just use the "Additional Drivers.." application. See here. It will tell you if there are any additional drivers that are needed or appropriate for your hardware.

Onboard graphics, I assume Intel Graphics, works quite well in general and does not require additional drivers, but I'm not sure.

0

Thanks mike to clarify I have this model:

http://www.expertreviews.co.uk/laptops/1302328/acer-v5-122p

The graphics is an onboard amd raedon chipset according to the datasheet.

Unfortunately on Elementary you can't get 'additional drivers.' However, I discovered you can install 'elementary tweaks' which puts a search bar in the top right hand corner.

http://www.elementaryupdate.com/2013/08/top-things-to-do-after-installing-luna.html

That allows me to get the additional driver options.

I may give Elementary OS 64bit one more shot after installing the additional drivers just to see if it makes any difference.

I know you said you shouldn't update the kernel but in that link it shows a quick and easy way to update to 13.04 kernel. That also might be worth a shot.

If all else fails I'm going to have to install 'ubuntu' then strip it down. For whatever reason after installing Xubuntu it wouldn't recognise my usb internet dongle and that is pretty critical for me.

I remember having this issue before. I tried both the latest version and two previous versions of Xubuntu.

It's odd that you say Kubuntu is faster than gnome. I always thought gnome was leaner that kde?

TBC...

Edited by iamthwee: added screenshot

1

It's odd that you say Kubuntu is faster than gnome. I always thought gnome was leaner that kde?

I know, it's weird, but it's my impression in general. I know that KDE is "heavier" (i.e., more RAM usage, a bit longer start-up time), and it's still a bit heavier than Gnome 3 (which is significantly heavier than previous versions of Gnome). However, for some reason, I find it to be just faster overall when you use it. At least, that's my impression (note that my experiences with Gnome are a bit limited, since I love KDE and use it almost exclusively). My guess is that because KDE relies on Qt (which is where the relative "heaviness" comes from), which is a much more comprehensive GUI library, things are more homogeneously implemented, and thus, faster. Gnome is a lot more of a patchwork of different components, which leads to overhead for gluing them together. At least, that's the best explanation I can find.

The graphics is an onboard amd raedon chipset according to the datasheet.

That graphics card will require a proprietary driver (which you should be able to find through "Additional Drivers..."). The driver for Radeon cards is the Catalyst driver. I guess this is the one to download (but try going through Additional Drivers.. first).

I think that the open-source graphics drivers for Radeon cards are pretty bad, but only because the drivers that AMD provides for Linux are very good, so there isn't much need to write good open-source alternatives for them. Long story short: Nvidia provides really bad drivers for Linux so people write and maintain as-good-as-possible open-source drivers (called "nouveau"); Intel contributes actively to the development of open-source drivers and Linux-kernel modules for their graphics chips (integrated to motherboards), so the open-source drivers are the "official" drivers for Intel graphics chips; and, AMD does a very good job of developing Linux versions of their drivers (they are basically as well-maintained and actively-developed as their Windows drivers), so there is no need to provide good separate open-source alternatives. But, the drawback is, of course, that you need to install those AMD graphics drivers if you have an AMD graphics card, and they are not installed by default (only open-source drivers are installed by default).

From the hardware specs of your computer, you should have no problems running any current version of Linux. I'm sure that installing the AMD drivers will have a big impact, because it really should not be sluggish at all with the hardware you have there. My installation of ElementaryOS runs just a little sluggish (but tolerable) on a 7 year old laptop with only 1Gb of RAM, a crappy old CPU and GPU, and only a small and slow 100Gb HDD.

Votes + Comments
Perfect
0

OK so, basically my internet dongle is having no success whatsoever on the latest versions Ubuntu or Xubuntu. Since my internet dongle works right out of the box on elementary OS I'm going to install Xubuntu 12.04

Since elementary OS is based on Ubuntu 12.04, it uses a rather outdated kernel. If you have any hardware issues, you might be able to fix them by installing a backport of Ubuntu's 13.04 Kernel.

So I have a few options. First I'm going to install elementary OS 64bit and try the 'additional drivers' option. If there are still speed issues, I'm going to try that link you posted on AMD's site. (Question how do you install the driver? Is it a .deb file or something?)

If all else fails... I'm going to go with Xubuntu 12.04 as the speed seems OK and I know the my internet dongle works with this version.

Thanks for the help.

0

update

So it was the drivers after all. After installing the drivers in that link my system is running smoothly :) And the animations work as well.

Bit tricky to install in linux. First I had to extract the zip file, then I had to give myself permissions to run it using chmod +rw.

Then I had to run it from the terminal ./the_name_of_the_file.run

And all is fine.

So all I have to do now is install the 64bit version of elementaryos although it seems fine at the minute.

0

Was about to throw in the towel again... I don't know what was happening but it took about 10 tries to get the 64bit version of elementary os onto my bootable usb drive with unetbootin. It just wouldn't recognise the media 'saying missing Operating system.'

On about the tenth try, luck or I just don't know it worked.

Then to my dismay with the 64bit system I realised my usb dongle was working but the wifi wasn't. Luckily the solution WAS to install the latest kernel which can be found in the link, 'ten things to do after installing elementary os'. Luckily updating the kernel was a one click install.

So now, I'm just about to install 64bit version of chrome, Lamp, sublime and virtual box. Pheww. It's taken a week to get right and I hope I don't have to reinstall this anytime soon.

I can definitely see why linux is most definitely NOT for newbies.

Other than that I'm thrilled. This little laptop is gonna be perfect when I move out and need to throw something small in my backpack.

Edited by iamthwee

0

Since this system has, in modern terms, a slow running CPU (1GHz IS slow, even with 2 cores). I would advize experimenting with a lower-impact GUI such as xfce or ice. There are a lot of options. The neat thing about Linux is that you can play with your system until it is JUST right (sort of like the 3 bears and Goldilocks). My first real personal Linux system was a Gentoo system I installed on my Dell D600 laptop. It took me a month of Sundays to get it properly configured, but once I did, it was a monster - ultra reliable, fast, and a pleasure to use! And, it ONLY had installed on it what I wanted - no extra performance-sucking cruft... :-)

0

Gentoo was your first system? You joking?! Yeah I do hear ya, my CPU is quite slow and ideally I want to be using it without the power source much.

I was thinking of putting on Lubuntu actually. But the whole thing hinges on getting my usb dongle to work so unfortunately, I have to rely on an OS that supports it out of the box.

0

Have you looked up your USB dongle's make and model to see if there are any reported issues with it in Linux? Usually, there are lots of active forums out there that contain reports of problems, and solutions to them, related to specific hardware. There might be a solution out-there (like a special driver, or a config modification, or a patch, or an NDISwrapper solution). If there is, then you would most likely be able to apply that solution to any distro that you choose to install (i.e., these close-to-kernel things are usually the same regardless of distribution (except for what is installed by default), they only pertain to the kernel and its modules (and some basic configs, like "blacklists"), which all works the same on all Linux systems, AFAIK).

I think that ElementaryOS is tailored to work "out of the box", which probably means that they package a lot of different drivers into the OS installation, just to make sure that all hardware will be covered. If it is able to make your dongle work, it probably means that there is a driver out there that will work for it, it's just that it is not part of the default distribution package of other Linux distros (like Ubuntu / Lubuntu / Kubuntu), but that doesn't mean that you can't install it too. You are probably one sudo apt-get install away from having a working dongle on any Ubuntu distro. That would be my guess.

Generally-speaking, for hardware support, the later the kernel version the better (although later kernels can have unfixed bugs that break support for hardware that used to work before, but sometimes, those bugs are also fixed in an even later kernel version). Fedora distributions (which offer different "spins", like Ubuntu) is generally a bit more up-stream in kernel version.

0

Thanks guys. You know what I went ahead and decided to use Lubuntu instead and to be honest you can get it looking OK with a few tricks.

On the plus side the battery life is incredible.

A few things I noticed working for me, first I installed Lubuntu 12.04, as I know for certain this version (kernel) works with my dongle.

Then I had to add the package manager for the raring ringtail kernel and update to this kernel. This allows me access to the wifi, unfortunately I don't have an ethernet connection, it seems most ultrabooks ship with this or dvd/cd drives. I'm sure DVDs and CDs have seen their days.

Then I had to install the proprietary drivers for my graphics chipset. But unfortunately lubuntu is seriously stripped down, so I had to do a
'sudo apt-get install gcc', and 'sudo apt get-install make'

After a reboot my system is using noticeably less CPU and everything renders nicely.

So there you have it. A fully working and seriously snappy OS with Lubuntu. I can partly see why people like to go down the gentoo/arch linux route now.

It certainly is tricky but to enjoy a secure system with low resources is fantastic.

My only gripe is the system shutdown hangs and the left click on my laptop touchpad doesn't work.

When I install a screenshot facility I'll post some pics.

0

So although this is a different request I'd like to keep it in this thread as it is related.

ATM I only have two issues now with my setup. I had a problem with right click not being detected on my touchpad... and found the answer here:

http://ubuntuforums.org/showthread.php?t=1388164

the other issue is I just can't power down my laptop, it just hangs. It is really irritating that I have to do a cold power down by holding the power button down. It's just bad isn't it.

I tried everything I could think of. Editing the grub files...
http://askubuntu.com/questions/125844/shutdown-does-not-power-off-computer

But nothing works. Seems like the issue occurred when I updated the kernel but I needed to do that to get the wireless drivers to work. Could also be due to using the proprietary drivers for my onboard graphics card. But without those my computer grinds to a halt and the fan constantly whirrs.

Any ideas? The power off seemed to work on the original kernel for elementaryOS which uses ubuntu as its base.

That literally is my one and only issue. Would love if I could fix this one. I hope...

0

The system shutdown and sleep/hibernate/wakeup stuff is a known issue with some Linux 3.x kernels. This has been an ongoing work in progress. I think that some of the newest kernels have pretty much cleared this up, but I run Scientific Linux 6 (a Red Hat Enterprise Linux clone, much like CentOS) on my old Dell D630 laptop (a 2.6.32 kernel) and it has no problems with that stuff. It was a bug introduced in some of the 3.x kernels (major changes from 2.6.x). Do some Googling now that you have the system running well - you will find out what is what in that regard and can act accordingly.

BTW, have you tried shutting it down via the command line? IE, "sudo shutdown -h now", or "reboot" and then hitting the power button when it gets to the BIOS/POST?

Edited by rubberman

0

From our talks in the chat room, the issue seems to be that you have upgraded to kernel version 3.8.x, from the original 3.2.x. The problem is that you have kept the graphics driver (Catalyst 13.x) that you installed for the 3.2.x kernel. The graphics drivers are very tightly linked to the kernel, and having a mismatch between the two is a very bad thing. It may work, but it causes some problems, like hanging during the shutdown process.

You said you tried to re-install the graphics driver after the kernel upgrade, but that it failed, and so, you kept the old one. It appears that this is a known issue with kernel 3.8.x and later with your graphics driver (the ATI Catalyst drivers). Here are instructions on how to apply a patch to make it work:
http://henryhermawan.blogspot.ca/2013/03/amd-catalyst-patch-for-kernel-38x.html

0

Thanks guys, especially mike. I do believe that link above is likely to solve my issue however, the risk of messing my system up at the minute then having to reload all the software again is too great.

I'm running behind with a few jobs so work is a priority. Once everything settles down I will probably try it out. Doing a cold reboot isn't that much of an issue.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.