0

I'm trying to edit a TS-file which I fetched from my VU+ set top box.
First I tried to rename it from .ts to .mpeg, then I tried to read it into Avidemux.
The first question was if I want to index the file, which I did.
After a while (near the end of file) I got the following error message:
"Crash

Assert failed :i==nbAudioStream
at line 188, file /build/build-avidemux_2.5.6-1~getdeb2-amd64-ZGvDMc/avidemux-2.5.6/avidemux/ADM_inputs/ADM_mpegdemuxer/dmx_audio.cppADM_backTrack
dmxAudioStream::open(char const)
dmxHeader::open(char const
)
ADM_Composer::addFile(char const*, unsigned char, fileType)
ADM_Composer::addFile(char const*, unsigned char, fileType)
avidemux2_gtk() [0x4538f7]
FileSel_ReadWrite(void ()(char const), int, char const*, char const)
avidemux2_gtk() [0x52bc15]
HandleAction(Action)
guiCallback(_GtkMenuItem
, void*)

g_signal_emit_valist
g_signal_emit_by_name

g_signal_emit_valist
g_signal_emit

g_closure_invoke

g_signal_emit_valist
"

How can I solve this problem ?

3
Contributors
4
Replies
13
Views
3 Years
Discussion Span
Last Post by it@61@sec
0

I'm not familiar with TS or VU+ formats but, in general, you can not simply rename files and expect that they will be interpreted differently.

Is Avidemux capable of handling TS files?

0

Well, it should - but when I try to read the "raw" ts-file into Avidemx I get the same error message as given above..

.ts is the same as "MPEG transport stream" and is a common format used by satelite decoders when recording tv-shows.....

0

Are you sure it isn't DRM-encumbered? It may be encrypted on the box, so that you can't just download it and play with other stuff...

In any case, the current version of ffmpeg should be able to transcode .ts files to others. Do you have ffmpeg installed on your system? If not, download and install it.

There are examples in the ffmpeg manpage that show how it can be done.

0

ffmpeg is no longer available in my Ubuntu repository. It is replaced by avconv.
The file is NOT DRM-encumbered or encrypted in any way. I usually use VLC media player to play these files on my Ubuntu system (or on my Samsung Galaxy S2 as well).

I have used avconv version 0.8.5-6:0.8.5-1 to convert from .ts to .mpg. Then I'm able to load the file into OpenShot Video Editor, but Avidemux does not show anything even if it loads the file...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.