0

I recent created a .vimrc file in my home directory because in addition to syntax highlighting and auto indention I also wanted my tabs to be four columns wide and to be tabs and not spaces but now that I have my file setup I am unable to use backspace to remove a newline. When I start backspacing a line the cursor stops at the beginning of the line and will not delete the line move to the end of the line above. Any ideas?

" All system-wide defaults are set in $VIMRUNTIME/debian.vim and sourced by
" the call to :runtime you can find below.  If you wish to change any of those
" settings, you should do it in this file (/etc/vim/vimrc), since debian.vim
" will be overwritten everytime an upgrade of the vim packages is performed.
" It is recommended to make changes after sourcing debian.vim since it alters
" the value of the 'compatible' option. 
" This line should not be removed as it ensures that various options are
" properly set to work with the Vim-related packages available in Debian.
runtime! debian.vim 
" Uncomment the next line to make Vim more Vi-compatible
" NOTE: debian.vim sets 'nocompatible'.  Setting 'compatible' changes numerous
" options, so any other options should be set AFTER setting 'compatible'.
"set compatible 
" Vim5 and later versions support syntax highlighting. Uncommenting the next
" line enables syntax highlighting by default.
if has("syntax")
 syntax on
endif 
" If using a dark background within the editing area and syntax highlighting
" turn on this option as well
set background=dark 
" Uncomment the following to have Vim jump to the last position when
" reopening a file
if has("autocmd")
 au BufReadPost * if line("'\"") > 1 && line("'\"") <= line("$") | exe "normal! g'\"" | endif
endif 
" Uncomment the following to have Vim load indentation rules and plugins
" according to the detected filetype.
if has("autocmd")
 filetype plugin indent on
endif 
" The following are commented out as they cause vim to behave a lot
" differently from regular Vi. They are highly recommended though.
set showcmd             " Show (partial) command in status line.
set showmatch           " Show matching brackets.
"set ignorecase         " Do case insensitive matching
"set smartcase          " Do smart case matching
set incsearch           " Incremental search
"set autowrite          " Automatically save before commands like :next and :make
set hidden              " Hide buffers when they are abandoned
"set mouse=a            " Enable mouse usage (all modes)
set ruler
set shiftwidth=4
set tabstop=4
set hlsearch
set backspace=indent,start 
set noexpandtab
" Source a global configuration file if available
if filereadable("/etc/vim/vimrc.local")
 source /etc/vim/vimrc.local
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
endif
3
Contributors
4
Replies
24
Views
11 Months
Discussion Span
Last Post by Benjamin_17
0

I haven't seen this problem before in vim, and since I'm use to being able to backspace in vim it's hard for me not to see it as bug or problem that needs to be fixed.

1

To me, not a bug. The priors show that it's not a new problem and some folk have "fixed it." Here I think it's proper behavior and again, I'm running into more and more folk that demand that actions match what you see in Microsoft Word.

1

try changing this line set backspace=indent,start to set backspace=indent,eol,start

Votes + Comments
This is the correct answer.
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.