0

Guys, I’m having a lot of problems with my 64GB usb stick.
It worked fine till somehow I think I formatted in exFAT format (that happened in Ubuntu as I was trying to install something on it and I formatted it using I can’t quite remember which utility in Ubuntu), and that’s when the nightmare begun. Every time I’d insert that into the USB port I’d get a “USB needs to be formatted” message. So, I first of all tried to format that from exFAT to NTFS, and I almost managed (in Windows using the format F: /fs:NTFS command): it took about a day but when it reached the end at 100% there was an error message saying something about not being able to create a proper file system (sorry I don’t remember the exact words).
Anyway, I also tried to format that to FAT (in windows) running the following command:
Format F: /fs:FAT32 but I got this error:

F:\>format F: /fs:FAT32
Insert new disk for drive F:
and press ENTER when ready...
The type of the file system is EXFAT.
The new file system is FAT32.
Verifying 64000M
Format cannot run because the volume is in use by another
process.  Format may run if this volume is dismounted first.
ALL OPENED HANDLES TO THIS VOLUME WOULD THEN BE INVALID.
Would you like to force a dismount on this volume? (Y/N) y
Volume dismounted.  All opened handles to this volume are now invalid.
123146240 bad sectors were encountered during the format.  These sectors
cannot be guaranteed to have been cleaned.
The volume is too big for FAT32.

More than happy to sort this out in Ubuntu or windows, whatever, if it can be sorted out of course, but I’m struggling to get this back to work
thanks

7
Contributors
9
Replies
66
Views
2 Years
Discussion Span
Last Post by Reverend Jim
0

Right, very odd. The reason why I started a new thread was because I couldn't really save anything on that USB and kept getting that "format message". I reformat that again in exFAT and now I managed to save something on it, so the message doesn't come up anymore. Weird.
@Gribouillis I tried to format it to NTFS but it just won't do it.

0

I agree with Gribouillous (above) about using gparted. There are some command-line utilities in Ubuntu that can easily accomplish reformatting your USB drive, but gparted is very easy to work with, and is in the Ubuntu repository. The link Grib provided shows some basic instructions on how to get started with gparted. I see this thread was started a month ago. Have you had success with your flash drive yet?

0

First, erase the boot/partition sector - with linux: dd if=/dev/zero of=/dev/sdX count=1
This will erase the boot/partition sector. Then use fdisk to create a new partition for whatever file system type you want. Then format that with the file system desired as in: mkfs -t fs-type /dev/sdX1
The fs-type option can be vfat, ntfs, ext2, ext3, ext4, etc. For current Windows systems, ntfs is a good option. The vfat (fat32) is not really a good idea other than being more universally usable.

0

Be sure your usb-stick is mounted (or unmounted) and you are using Ubuntu-Linux (not Windows) :

1.) plug out your usb stick and then plug it in again
2.) look which name the device has in your file-manager : the usb-stick is mostly on /dev/sdc
3.) in case your usb-stick is really on /dev/sdc and in case gparted in Ubuntu does not help because of bug in libparted you could try to get offline from internet and then to start in your terminal with : sudo su
and in su-modus you then type : gparted
Then there try in gparted to delete your usb-stick, then create a partition table on /dev/sdc and in the end try to format your usb-stick with filesystem ntfs (not FAT32)
4.) in case step 3.) does not work then you could do this, but this lasts very long and is a stress test for your usb-stick to make it factory-fresh-new with terminal :
type in there in terminal :
sudo su
and then
dd if=/dev/zero of=/dev/sdc (be sure usb-stick is really sdc)

5.) after 4.) then usb-stick is really deleted and new-born and should be able to be formatted with gparted.

Edited by dschinn1001: detailed description

1

You can do it from Windows. Open a command shell as Aministrator and run DISKPART.EXE.

First, list the mounted disks

list disk

Select the usb stick by its disk number (let's assume it is disk 1)

select disk 1

Wipe the disk

clean

Create a primary partition

create partition primary

Select the new partition and make it active

select partition 1
active

Format as FAT32 or NTFS

format fs=ntfs quick

or

format fs=fat32 quick

now get out

exit

That should do it.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.