0

Hello all.
I have a small app that only runs on FreeBSD, and have a host where i dont have root.
That app requires many libraries, most of them i have, but the problem , that app doesnt look for libs at current folder.
I tryied running the app on a virtual machine, and when i put required lib files to the /usr/lib it doesnt ask for them .
Is there any other lib/ folder that can is writable by any user ?
Thanks in advance.

2
Contributors
2
Replies
3
Views
8 Years
Discussion Span
Last Post by jen140
0

You don't have to have the libraries in /usr/lib in order to compile an application. Take a look at this page:
http://linuxmafia.com/faq/Admin/ld-lib-path.html

You *can* set LD_LIBRARY_PATH but it is not recommended. Please see if the site satisfies the compilation issue for you, if not then please post the name(s) of the software(s) you are trying to compile

0

Thanks for the ideia , but it didnt worked .
I was trying to compile ghost++ (warcraft 3 bot) with some modification from other person who doesnt appear online now .
I dont know why it doesnt work but i've seen the help file that had the same ideia of setting the LD_LIBRARY_PATH.
The problem is that i dont have root on the host where i tryied to compile it.
But anyway, thanks for your answer.
The person who asked me to fix it no longer requires it, so solved.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.