I've discovered a weird problem with my Linux Mint-system (Linux Mint 18).
After rebooting my system (or restarting as well) I got the GRUB menu, but my keyboard is not responding...
So I have to wait for the timeout to get my system booted.

The keyboard is wired to the computer through an USB-connection. So it's not wireless.
And it works OK as soon as my system has booted.. (?).

I have installed/loaded Linux kernel 4.4.142, 4.4.143 and 4.4.145.
When running kernel 4.4.142 Virtualbox and VMWare Workstation works as it should, but when I try to use 4.4.143 or 4.4.145 they both refuse to load.
So I want to be able to choose which kernel to run depending on what I want to do.. :-)

I've seen that but it usually comes down to USB keyboards, BIOS and settings in the BIOS. Try what options you have for USB legacy and keyboard support in the BIOS. Be aware there is no one fix for this but many. I'm sharing the one I run into.

But it's very strange that it worked the first time I did a reboot after changing the GRUB config. But then it suddenly stopped working.
OK, I'll check the BIOS.

The problem was solved when I restored BIOS to default values.
I don't know what has been changed (I have not changed any values), but now it seems to work.
The GRUB is a beta-version.... (?)
Thanx!

I couldn't write this is always the fix, only that it's the most common one I've used.

In any case, when I restart it straightforwardly run windows 10 (No decision OS menu) show up again Go into <ubuntu> and select grubx64.efi and it should boot up. be that as it may, as long as no mistakes, you ought to have the option to reboot now and get grub first. After you have transformed it back to UEFI mode, at that point reboot once more into Windows