0

Hi.

I've had this problem with all my ubuntu installations (two, to date), and I can't find my way around it..

Even when I switch to runevel 3, by booting with special options or typing telinit 3.. Even THEN, X server starts up, and that's the ONE thing I need not to start up so I can install NVidia drivers :sad: Can someone tell me how to stop X?

6
Contributors
6
Replies
7
Views
11 Years
Discussion Span
Last Post by EdwinStarr
0

What I figure is that the X server is configured to automatically start up even in runlevel 3. You could of course, change the configuration files so that X doesn't start up in runlevel 3. But it's probably easier to use the shell to quit it temporarily. You can try quitting from the interface, so in the login window, look for "exit to prompt" or something siimilar. If it works, then you can most likely proceed. If that doesn't work, try quitting the service (replace xdm with gdm or kdm if that's what you're running).

# /etc/init.d/xdm stop

If that doesn't work, then run something like this at the prompt:

# ps -aux | grep gdm

(of course, if you're running kdm, replace "kdm" with "gdm")

Look for a line that shows gdm, find its process id number (PID), and run the following:

# sudo kill [B]PID[/B]

Hope this helps

0

I searched all over the web for an answer to the runlevels problem in Ubuntu and didn't find one that solved my problem. The way runlevels are configured in RedHat (for at least 11 years since I started using RedHat) makes far more sense.

After about a day working on it, I got it working the way I wanted (more RedHat-like) and wrote a kind of HOWTO about it called Proper Runlevels in Ubuntu

0

init 2?

...would do exactly nothing: 2 is the default graphical runlevel in Ubuntu and is identical to runlevels 3, 4, and 5. If you're suggesting it as a kernel "command-line" option, it would do nothing even if the runlevels were configured differently, since the command-line is parsed by the "upstart" scripts, which don't recognise it -- the purpose of my version of the rc-default script is to add exactly this support to the kernel command-line.

0

Hi guys,

Myself NYK, according to me Ubuntu is the powerful operating system of linux. It is developed by HCL. I have used this operating system.its amazing. Thanks

<remove fake signature and links to dating sites>

0

Hi,

I too just found out that the run levels in Ubuntu were different. I was used to PCLOS 2007 Final's way of using run levels on my web server. Now I have invested much time into Ubuntu w/kde3 and find out the run levels are dealt with much differantly. Thank you EmmetCaulfield, and others Emmet... refrences, I may be able to get a hold of my run levels. BTW, I use Hardy and Ubuntu changed run level handles again for it. I do not like the way Ubuntu has done this much. It may not be intirely Ubuntu's idea, I noticed some Debian is like that too like Lenny I think.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.