0

Iam a linux newbie who feels the need to famalirize myself with the linux environment. For some reason, I think the headache of installing linux is worth it. maybe not right now because Iam experience a lot a problem just getting started.

I just recently install fedora core 5 on my toshiba satellite A60/65 laptop. Fedora Core 5 was installed sucessfully but it freezes at the point after I enter my username and password. When I initially install fc 5, I was able to briefly play around on the desktop for about 30 sec then my system froze. I had to press the power button to shut it down. Every time I repeat this process, the booting process keeps regressing. Now its at the point where the system freezes immediately after I enter my username and password. if I do it the interactive startup it still freezes.

Is there anyone that has an idea as to how this can be fix? I will really appreciate whatever input I get. Remember Iam a newbie so please try to keep it in simple terms.

3
Contributors
19
Replies
20
Views
10 Years
Discussion Span
Last Post by jbennet
0

Have you tried a command prompt login?

Press CTRL-ALT-F1 when you see the graphical login page, and then you'll be prompted to enter your name and password in the shell. Your password won't be visible to keep it from getting stolen.

If it logs in, try typing random stuff onto the console; you won't hurt it. Just to see if it freezes or something. Here are some random Linux commands that won't hurt anything:

# ls
# cd ~

If it does freeze, you've got a deeper problem. If not, you can log out by entering "exit" and pressing return. And then it's most likely related to your login software. To return to the graphical login, press CTRL-ALT-F7.

Hope this helps

0

I was able to login with cmd prompt and successfully enter unix commands into the console without my computer freezing. I its at all related to the login software, how would I go about fixing this problem?
Thanks a lot..I appreciate all your assistance.

0

My mind's a bit foggy, so please help me - which login manager are you using, and which display manager are you using? (Gnome/GDM, KDE/KDM, etc.)

The first thing you should probably do is try switching environments - the login window should have some option that allows you to choose between Gnome, KDE, X11. Choose a different one and see what happens when you login.

By the way, if you ever get caught in an X11 session (about 3 terminal windows and a blank desktop), you can exit by typing "exit" in the main/default terminal window.

0

the fc 5 installation came with a default login manager which Iam not sure what it is. I do have another option for GNOME/GDM and thats about all the options including the failsafe GNOME . I also tried all the different options and got the same result, but I was able to get into the failsafe terminal. For the failsafe terminal there was one blank desktop and a terminal which gives me the assumption that is the X11 session.

0

For the failsafe terminal there was one blank desktop and a terminal which gives me the assumption that is the X11 session.

Yes - so now we've pretty well narrowed it down to either Gnome, or the login manager, which I've determined is GDM.

I'm still unsure what the problem is; and although it's possible to find the cause of the problem, it might become very, very difficult from the command line. The broken part of the OS is the very thing we need to fix it (or at least aid by making it easier).

I was going to suggest installing KDE, but I changed my mind because the install would simply be too difficult for you to follow (mainly, there's far too many variables that could affect the instructions I give you, making a lot of it guesswork).

At this point, the only thing I can think of right now is a reinstall of Fedora. It's possible that files somehow got mangled during the install process, which could be causing the problems you speak of. If the problem persists, then we know it's a hardware problem.

0

Thanks for helping me narrow down the problem...I think reinstallation would be the best route to take. KDE may also be another option given during the installation process which will negate having to install KDE seperately. I was also wondering if the problem might have any thing to do with the partitioning because I used the default partion set during the installation.

Would you suggest manually partitioning the disk with grub or just stick with the default partion? I have little experience with partitioning which is why I used the default partioning .
Is there anything in specifics that you would suggest I pay special attention when I reinstall FC5 ?

0

I was also wondering if the problem might have any thing to do with the partitioning because I used the default partion set during the installation.

Would you suggest manually partitioning the disk with grub or just stick with the default partion? I have little experience with partitioning which is why I used the default partioning.

I really kind of doubt it... usually if there's partition problems, you'll get all sorts of hard-disk related errors when booting such as "cannot load extension" and the like. When installing again, I would simply suggest making sure that it takes over the entire drive. Manually partitioning probably won't do much good.

Is there anything in specifics that you would suggest I pay special attention when I reinstall FC5 ?

Well, I'd make sure that you don't mess around too much with the installation packages; it's fine to add packages, such as KDE, but certainly don't remove any until after the installation and you're sure that Fedora is working properly.

0

maybe login without using gdm might help?

boot up with the init 3 parameter (from grub) in order to boot to a command line and then login and type startx

0

I reinstalled linux on my laptop. THis time I allocated all the remaining disk space to the root mount point. After installation, it seemed like everything worked fine. I could finally see some light at the end of the tunnel. I was able to mess around my new linux environment for about a good ten minutes, then it frooze again. Each time I turned it off and log back into the system, it took lesser time to freeze and eventually iam unable to even get past the login point.

If at all its a hardware problem, what will I need to do to rectify it? I really want to experience the benefit of using linux, but this is killing me.

Eventhough I want to have the full linux experience, Iam some what getting frustrated with the whole installation process. will it be much better if I can somehow install window back on my laptop and just run linux from a virtual machine instead?

0

someone suggested that it might be a graphic card problem. THis doesn't compute much to me, obviously because iam not very knowledgeble with linux. But what do you guys think about the graphic card being the issue?

By the way my graphic card is radeon mobility 7000 IGP

0

someone suggested that it might be a graphic card problem. THis doesn't compute much to me, obviously because iam not very knowledgeble with linux. But what do you guys think about the graphic card being the issue?

Perhaps... I've read a report of freezing happening shortly after login due to insufficient video memory. Could you provide the amount of memory in your computer, and in your video card?

You could try some different boot parameters; when GRUB loads, try adding some commands like noacpi and see what happens.

Probably the best thing to solve this would be to use a different Linux distro. Fedora needs oodles of RAM, and using this on your laptop probably isn't going to help. You may want to try Debian instead; it uses far less RAM and requires about the same skill level to use as Red Hat.

0

I think I finally have a solution to the madness.

What I did was login to cmd prompt and executed startx. This is what I got:


xauth: creating new authority file /root/.serverauth.2450
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority

Fatal server error:

Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

Xlib: connection to ": 0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.

xinit: unable to connect to X server
xinit: No such process (errono 3): Server error

Then I executed 'less /etc/X11/xorg.conf' and got:

#Xorg configuration created by system-config-display

Section "ServerLayout"
indentifier "single head configuration"
screen 0 "screen0" 00
inputdevice "Keyboard0" "CoreKeyboard"
inputdevice "Synaptics" "CorePointer"
inputdevice "Mouse0" "AlwaysCore"
EndSection

Section "Files"

#Multiple FontPath entries are allowed ( they are concatenated together)
#By default, a font server independent og the X server is
#used to render fonts.

FontPath "unix/:7100"
EndSection

Section "Module"
load "dbe"
load "extmod"
load "fbdevhw"
load "glx"
load "record"
load "freetype"
load "type1"
load "synaptics"
load "dri"

EndSection

section "Monitor"

###comment all HorizSync and VertSync values to use DDC:

identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"

###comment all HorizSync and VertSync values to use DDC:

HorizSync 31.5-37.9
vertRefresh 50.0 -70.0
option "dpms"

endsection

Section "Device"
indentifier "Videocard0"
driver "radeon"
VendorName "videocard vendor"
BoardName "ATI techonologies inc radeon mobility 7000 IGP"

endsection

Section " screen"

Idetifier "screen0"
Device "videocard0"
monitor " Monitor0"
defaultDepth 24
SubSection "Display"
viewport 00
depth 24
modes "800x600" "640x480"
endsubsection

section "dri"
group 0
mode 0666
endsection

I had to again login from cmd prompt as root and re-execute startx.
after getting the error msg again, I executed this command to remove this file:
rm -f /tmp/.X0-lock

follow by the startx cmd which took me directly to the desktop.

0

this absolutely takes care of the freezing problem I was having. My next task is figuring out how to make linux use my wireless LAN.

0

Fatal server error:

Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

Xlib: connection to ": 0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.

xinit: unable to connect to X server
xinit: No such process (errono 3): Server error

This error is given because you've already got X running (the login window). If you want to use startx, the proper way is usually to quit it (usually there's a menu option to do this, or some users simply run in a different runlevel).

By deleting the .X0-lock, you are simply getting around this limitation. It's not really a bad thing, as far as I know, but it's certainly clumsy.

It's a pretty good guess to say that your login manager (in this case, it's GDM) is causing the freezing up, and I think this is due to insufficient video memory. To solve this, I suggest installing a login manager that uses less resources such as Entrance. Installation should be easier now that you've figured out how to get into Gnome.

0

i run the GDM from centos 4.4 on a server with 1mb Video ram just fine so i dont see why it would be that

0

i run the GDM from centos 4.4 on a server with 1mb Video ram just fine so i dont see why it would be that

Well, because when the computer runs out of video memory, it starts using system memory, which is not only slower, but if that is also small (which I assume is true in this case), the computer will run out of memory.

And CentOS uses a lot less resources than Fedora Core 5, so I still think that's the cause of the problems.

0

well, my video memory is 64mb and my ram is 512mb..I'll will try and download a login manager that uses less memory soon as I can get linux to automatically detect and connect to wireless connection within range. .....I'll probably be starting another thread for that after searching for similar thread.

Just want to thank you guys for all your help and insights.

0

Just out of interest, how fast are your clock speeds on the laptop? 64 MB of video ram is actually quite adequete to run GDM, and shouldn't be causing any problems (I had a PII running Red Hat 9, and that worked more-or-less).

There could also be a problem of having too many services running in the background, which although shouldn't be a problem RAM-wise (512 MB is plenty), it could be hard for your processor to keep up, thus causing it to crash.

Just a thought.

0

i think its an ACPI problem

ive had problems in the past that everytime my laptop checks its temp/battery status the pc slows to a crawl

at the GRUB ((bootloader) screen push one of the arrow keys to stop the countdown then follow the instructions shown there in order to add the lines: noapic nolapic noacpi acpi=off

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.