0

Alright, well here's my problem: Firefox no longer works on my debian system. Since I just switched to kde, I have Konqueror, but I had this problem before.

Everytime (or most of the time) when I open up firefox, it comes up and an error message comes up saying: "No XBL bindings for browser." Then it justs quits itself.

I tried reinstalling firefox, and removing then installing it again; either way I end up with the same result. Does anyone have any ideas?

3
Contributors
6
Replies
7
Views
10 Years
Discussion Span
Last Post by jay.smith
0

This explains your problem pretty well:http://www.mozilla.com/en-US/firefox/releases/fix-extensions.html

Specifically, how many extensions did you have installed before Firefox started acting up? Those instructions might not work as they were written for Firefox 0.8, but try mucking around in ~/.mozilla/firefox/extensions/ or something similar. If there's nothing really important, delete (or move) the extensions to another directory to see if this allows Firefox to startup.

0

alright, well that might explain it, but I thought apt-get remove firefox would remove everything firefox, including the plugins. Doesn't it? and if it doesn't then how do I remove my plugins? I can't find them in ~/.mozilla/ or /usr/share/firefox/ , or any other logical places.

0

So it's worked before on your Debina system, right?

I'm not entirely sure if apt-get remove firefox will remove the extensions and plugins, especially if they're stored in each user's home folder. I'm going to take a look on my Debian system to see if I can't find out where exactly the Firefox plugins are installed, but in the meantime you may want to try ls -a ~ to see if there's something in there.

0

I just checked now, and it seems that plugins are stored in ~/.mozilla/plugins and ~/.mozilla/firefox . What I would recommend is moving or deleting the entire .mozilla folder that resides in your home directory, as Firefox will automatically create a new one at startup if one is non-existent:

rm -rf ~/.mozilla

Hopefully that will work for you.

0

Alrighty, well I'll be doing that, however IceWeasel (GNUzilla's firefox) seems to be working quite well with my extensions. It checked their compatabilities with itself the first time it started up. Thanks a lot for the help!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.