0

You would think someone would've asked this question already, but I am having trouble getting GTKpod to recognize my ipod when I connect it. I know that GTKpod isn't the problem, it my system's mounting procedure. When I plug in my iPod, this goes through my /var/log/messages: (same with dmesg)

usb 3-3: new high speed USB device using ehci_hcd and address 3
usb 3-3: configuration #1 chosen from two choices
scsi1 : SCSI Emulation for USB mass storage devices
  vendor: Apple       Model: iPod                    Rev: 1.62
  Type: Direct-Access                                 ANSI SCSI revision: 00
SCSI device sda: 7999487 512-byte hdwr sectors (4096 MB)
sda: write-protect is off
SCSI device sda: 7999487 512-byte hdwr sectors (4096 MB)
sda: wirte-protect is off
  sda: sda1 sda2
sd 1:0:0:0: Attached scsi removable disk sda

That's it. I don't know where it mounts it, if it mounts it, and I cant just mount /dev/sda1 /media/ipod because I need to specify a filesystem type. and HTF+ and FAT32 aren't options.

This is a 4GB iPod Mini, I think it's almost a year old right now. It was used on a Windoze computer for 6 months or so, so it should have a FAT32 file-system on it. Any help would be excellent!

(side-note) Yes, linux, I did see your link to ipodlinux.org, but I want this music off of it before I even think about installing linux onto it.

4
Contributors
9
Replies
10
Views
10 Years
Discussion Span
Last Post by linux
0

filesystem type should be of type "vfat" for FAT32 partitions but ive only ever tried this with external HDDs

0

Well, I tried to tell it that sda1 was a FAT fs, but it said it wasn't. T_T *cries in waterfalls* thanks for the tip, but apparently there are more mysterious things working here...

0

So what error messages are printed out when you execute this command:

mount -t vfat /dev/sda1 /media/ipod

If indeed Linux can't recognize the filesystem type, then you may want to reformat the device and make SURE it's Fat32.

0

you havent done something silly like having a mac formatted ipod have you?

That's kind of what I was getting at... ;)

0

Lol, well I got it to connect; and no, I didn't have a mac formatted ipod XD

Apparently I have 3 ports: 2 on the left that are 2.0, and one on the right that's 1.0. I thought it was the other way around ^_^U Point being, if I plug it into the slot on the right (the one I usually use) It won't be able to read it or mount it correctly. If I plug it in the left, it works. So, uhm... what? Why? Whatever, as long as it works...

And while we're all here, what would be the advantages of putting Linux on my ipod? I'm asking here, instead of going to the website, to see if anyone has done it.

0

>what would be the advantages of putting Linux on my ipod?
There's a whole ton of things you can do when you install Linux on your iPod. Lots of applications are being ported to iPod Linux, allowing you to play games such as Doom I and II, watch video on iPod Nanos, even carry around a scaled-down version of Wikipedia :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.